Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 173786 - unable to display menu item in ja locale
Summary: unable to display menu item in ja locale
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-11-21 05:48 UTC by Lawrence Lim
Modified: 2014-03-26 00:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-05 17:44:30 UTC


Attachments (Terms of Use)
screenshot in ja_JP locale (deleted)
2005-11-21 05:51 UTC, Lawrence Lim
no flags Details
screenshot in en_US locale (deleted)
2005-11-21 05:52 UTC, Lawrence Lim
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 322001 None None None Never

Description Lawrence Lim 2005-11-21 05:48:56 UTC
Description of problem:
The menu item for switching to mail,contacts,calendar and tasks is missing in
the ja locale.

Version-Release number of selected component (if applicable):
evolution-2.4.1-7
evolution-data-server-1.4.1.1-1
evolution-webcal-2.4.1-1

How reproducible:
Always

Steps to Reproduce:
1.LANG=ja_JP.UTF-8 evolution
2.third item on the menubar (Alt-V)
3.first item in the sub-menu (W)
  
Actual results:
No option in ja locale

Expected results:
Similar to en_US

Additional info:
Tried with CJKI and some european locales, they all work fine.

Error Message is as follows:

# LANG=ja_JP.UTF-8 evolution
adding hook target 'source'

(evolution:7156): XML-CRITICAL **: attributes construct error


(evolution:7156): XML-CRITICAL **: Specification mandate value for attribute ã¡ã¼ã«


(evolution:7156): XML-CRITICAL **: attributes construct error


(evolution:7156): XML-CRITICAL **: error parsing attribute name


(evolution:7156): XML-CRITICAL **: attributes construct error


(evolution:7156): XML-CRITICAL **: xmlParseStartTag: problem parsing attributes


(evolution:7156): XML-CRITICAL **: Couldn't find end of Start Tag menuitem line 1


(evolution:7156): XML-CRITICAL **: attributes construct error


(evolution:7156): XML-CRITICAL **: Specification mandate value for attribute é£çµ¡å


(evolution:7156): XML-CRITICAL **: attributes construct error


(evolution:7156): XML-CRITICAL **: error parsing attribute name


(evolution:7156): XML-CRITICAL **: attributes construct error


(evolution:7156): XML-CRITICAL **: xmlParseStartTag: problem parsing attributes


(evolution:7156): XML-CRITICAL **: Couldn't find end of Start Tag menuitem line 1


(evolution:7156): XML-CRITICAL **: attributes construct error


(evolution:7156): XML-CRITICAL **: Specification mandate value for attribute ã«
ã¬ã³ã


(evolution:7156): XML-CRITICAL **: attributes construct error


(evolution:7156): XML-CRITICAL **: error parsing attribute name


(evolution:7156): XML-CRITICAL **: attributes construct error


(evolution:7156): XML-CRITICAL **: xmlParseStartTag: problem parsing attributes


(evolution:7156): XML-CRITICAL **: Couldn't find end of Start Tag menuitem line 1


(evolution:7156): XML-CRITICAL **: attributes construct error


(evolution:7156): XML-CRITICAL **: Specification mandate value for attribute ã¿ã¹ã¯


(evolution:7156): XML-CRITICAL **: attributes construct error


(evolution:7156): XML-CRITICAL **: error parsing attribute name


(evolution:7156): XML-CRITICAL **: attributes construct error


(evolution:7156): XML-CRITICAL **: xmlParseStartTag: problem parsing attributes


(evolution:7156): XML-CRITICAL **: Couldn't find end of Start Tag menuitem line 1


(evolution:7156): Gdk-CRITICAL **: gdk_gc_set_foreground: assertion `GDK_IS_GC
(gc)' failed

Comment 1 Lawrence Lim 2005-11-21 05:51:48 UTC
Created attachment 121288 [details]
screenshot in ja_JP locale

Noticed that the sub-menu is empty.

Comment 2 Lawrence Lim 2005-11-21 05:52:33 UTC
Created attachment 121289 [details]
screenshot in en_US locale

The original version in en_US.

Comment 3 Dave Malcolm 2005-12-09 07:40:02 UTC
I've submitted a fix for this upstream for approval

Comment 4 Dave Malcolm 2005-12-12 20:00:57 UTC
Patch committed to upstream CVS; should be fixed in 2.5.3

Comment 6 Lawrence Lim 2005-12-19 04:39:35 UTC
rawhide at the moment is still evolution-2.5.2-2, changing status to MODIFIED so
it can be looked again at the next round of Bug Sweep.

Comment 7 Dave Malcolm 2005-12-19 22:55:13 UTC
(looks like I missed the deadline for the 2.5.3 tarball, so this will probably
be fixed in 2.5.4)

Comment 8 Dave Malcolm 2006-01-05 17:44:30 UTC
Fixed in rawhide (evolution-2.5.4-2)


Note You need to log in before you can comment on or make changes to this bug.