Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 173569 - Issues with making totem the default cd player
Summary: Issues with making totem the default cd player
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: totem
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
: 178770 (view as bug list)
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2005-11-18 05:17 UTC by Matthias Clasen
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-04-14 20:19:28 UTC


Attachments (Terms of Use)

Description Matthias Clasen 2005-11-18 05:17:26 UTC
Here is a list of issues Ray and I came across when we played around with adding
a separate menu entry for totem as `CD player`:

- When started as totem /dev/cdrom, totem takes a too long time to start
  playing the cd which is in the drive
- Starting it as totem cdda:// starts playing much faster, but leaves the 
  ugly cdda:// url in the window title
- If no cd is in the drive, both methods bring up an error dialog, which 
  we do not want
- The "Movie" menuitem in the menubar is inappropriate when using totem
  as a CD player. Can it be changed to a more neutral "File" ?
- In fullscreen mode, the controls don't vanish again after they have become
  visible once
- The "Sidebar" toggle button is a bit unusual (I would almost say ugly) for
  apps with togglable sidebars. Is there a specific reason that toggling it
  from the menus is not enough ?

Comment 1 Bill Nottingham 2005-11-18 20:14:11 UTC
So, would we patch out the CD-playing in a) gnome-media b) sound-juicer?

Comment 2 Bill Nottingham 2005-11-18 20:20:20 UTC
Um, what about CDDB support?

Comment 3 Christopher Aillon 2006-01-27 22:14:15 UTC
*** Bug 178770 has been marked as a duplicate of this bug. ***

Comment 4 Ray Strode [halfline] 2006-01-27 22:16:08 UTC
I think we're going to switch to rhythmbox instead.

Comment 6 John Thacker 2006-04-14 20:19:28 UTC
totem now doesn't even have audio CD support at all, so I'm just going to close
this.  If anyone wants to edit the bug to refer to switching to rhythmbox
instead, feel free.


Note You need to log in before you can comment on or make changes to this bug.