Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 173530 - Print.h requires X11/Xauth.h
Summary: Print.h requires X11/Xauth.h
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-proto-devel
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Søren Sandmann Pedersen
QA Contact:
URL:
Whiteboard:
: 173884 176077 (view as bug list)
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2005-11-17 22:48 UTC by Patrice Dumas
Modified: 2014-06-18 09:08 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-09-08 22:32:20 UTC


Attachments (Terms of Use)

Description Patrice Dumas 2005-11-17 22:48:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
 X11/extensions/Print.h includes X11/Xauth.h but doesnt requires the package that owns that file:
#include <X11/Xauth.h>

Version-Release number of selected component (if applicable):
xorg-x11-proto-devel-0.99.2-1

How reproducible:
Always

Steps to Reproduce:
1. install and try to build
2.
3.
  

Additional info:

Comment 1 Mike A. Harris 2006-02-01 00:28:09 UTC
*** Bug 176077 has been marked as a duplicate of this bug. ***

Comment 2 Mike A. Harris 2006-06-27 16:44:54 UTC
Print.h needs to be examined to see if it should move to libXp package, or
if it should be refactored.



Comment 3 Matthias Clasen 2006-07-06 21:52:14 UTC
Add to FC6Destop tracker

Comment 4 Adam Jackson 2006-08-02 19:56:43 UTC
*** Bug 173884 has been marked as a duplicate of this bug. ***

Comment 5 Patrice Dumas 2006-09-09 22:47:29 UTC
In which version is it fixed? Print.h seems to be in 
libXp-devel-1.0.0-6
but there is still a Requires missing on libXau-devel

As a side note, X11/extensions/security.h which is in 
xorg-x11-proto-devel also includes <X11/Xauth.h>, so
xorg-x11-proto-devel should still also depend on libXau-devel. 

Comment 6 Søren Sandmann Pedersen 2006-09-20 21:53:20 UTC
I have added the Requires now; it will be fixed if/when releng moves the new
package into fc6.

Comment 7 Patrice Dumas 2006-10-01 20:37:30 UTC
Should I open a new bug for X11/extensions/security.h which is in 
xorg-x11-proto-devel and includes <X11/Xauth.h>?

Comment 8 Søren Sandmann Pedersen 2006-10-01 22:05:40 UTC
I already opened bug 207391 (but apparently forgot to cc you).



Note You need to log in before you can comment on or make changes to this bug.