Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 173442 - RFE: pre-populate yum's repodata cache for active repos as part of install
Summary: RFE: pre-populate yum's repodata cache for active repos as part of install
Keywords:
Status: CLOSED DUPLICATE of bug 173441
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-11-17 03:33 UTC by Jef Spaleta
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-11-17 13:07:27 UTC


Attachments (Terms of Use)

Description Jef Spaleta 2005-11-17 03:33:03 UTC
Description of problem:
as dicussed in #fedora-devel
the idea is to pre-populate repodata on disk so things like yum provides
or repoquery runs can be done against the local cache after ststen install
regardless of network state. This recovers some of the usefulness that
fedora-rpmdb allowed to run dependancy/provides queries.

Clearly, for fc5 it would be good enough to pre-populate just base. Though it
would be great to be able to pre-populate whatever repos are active at install
time in future releases.

Comment 1 Rahul Sundaram 2005-11-17 13:07:27 UTC

*** This bug has been marked as a duplicate of 173441 ***


Note You need to log in before you can comment on or make changes to this bug.