Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 173341 - /etc/udev/rules.d/50-udev.rules has no entry for /dev/fuse
Summary: /etc/udev/rules.d/50-udev.rules has no entry for /dev/fuse
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: udev
Version: 4
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On: 173345
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-11-16 14:16 UTC by Richard Dawe
Modified: 2008-05-13 08:46 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-11-17 21:38:35 UTC


Attachments (Terms of Use)

Description Richard Dawe 2005-11-16 14:16:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Fedora/1.7.12-1.5.1

Description of problem:
FUSE is Filesystem in Userspace, which was integrated into the 2.6.14 kernel. This is available on FC4 via the kernel-2.6.14-1.1637_FC4 package. FUSE's userspace communicates with the kernel via /dev/fuse. If /dev/fuse isn't present, userspace filesystems don't work.


Version-Release number of selected component (if applicable):
udev-058-1.0.FC4.1

How reproducible:
Always

Steps to Reproduce:
1. "modprobe fuse" as root.
2. ls -la /dev/fuse fails.


Actual Results:  /dev/fuse didn't appear.

Expected Results:  /dev/fuse should have appeared.

Additional info:

/etc/udev/rules.d/50-udev.rules has no entry for /dev/fuse.

FUSE ships with a udev rules file for creating /dev/fuse automatically:

[rich@katrina ~]$ cat /etc/udev/rules.d/40-fuse.rules
KERNEL="fuse", NAME="%k", MODE="0666"

This works.

Note that I'm in the process of packaging up the userspace component of FUSE for incorporation into Extras. I'll include FUSE udev rules file in that, until udev includes the /dev/fuse rule.

I've marked this as low priority, since there are currently no userspace packages for FC4.

Comment 1 Richard Dawe 2005-11-16 14:17:34 UTC
This is also true on x86_64.

Comment 2 Albert Strasheim 2005-11-17 15:09:11 UTC
Works for me:

[root@dogbert albert]# uname -a
Linux dogbert.sdsl.sun.ac.za 2.6.14-1.1637_FC4smp #1 SMP Wed Nov 9 18:34:11 EST
2005 i686 i686 i386 GNU/Linux
[root@dogbert albert]# ls -l /dev/fuse
ls: /dev/fuse: No such file or directory
[root@dogbert albert]# /sbin/modprobe fuse
[root@dogbert albert]# ls -l /dev/fuse
crw-rw----  1 root root 10, 229 Nov 17 17:10 /dev/fuse
[root@dogbert albert]# rpm -q udev
udev-058-1.0.FC4.1

Comment 3 Richard Dawe 2005-11-17 21:38:35 UTC
OK, today it works. I checked the kernel sources - /dev/fuse gets created
automatically by the module.

It must have been user error when I tried it before (twice - i386, x86_64).

Sorry for the bogus report.

Comment 4 Harald Hoyer 2008-05-13 08:46:00 UTC
# rpm -qf /etc/udev/makedev.d/99-fuse.nodes 
fuse-2.7.3-2.fc9.x86_64



Note You need to log in before you can comment on or make changes to this bug.