Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 173323 - Re-base vnc on modular xorg-x11
Summary: Re-base vnc on modular xorg-x11
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: vnc
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
: 174382 174711 (view as bug list)
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-11-16 10:47 UTC by Tim Waugh
Modified: 2007-11-30 22:11 UTC (History)
5 users (show)

Fixed In Version: 4.1.1-25
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-12-04 10:56:43 UTC


Attachments (Terms of Use)

Description Tim Waugh 2005-11-16 10:47:34 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Matthias Saou 2005-11-18 12:46:23 UTC
With modular X, could including Source2 be avoided?
It adds 42.6M to the source rpm...

Other than that, seems like simply replacing :

ext=%{buildroot}/usr/X11R6/%{_lib}/modules/extensions

with a nice "pkg-config xorg-server" call to the the extensions path could
be enough to fix the package for now.

Comment 2 Tim Waugh 2005-11-28 18:03:08 UTC
*** Bug 174382 has been marked as a duplicate of this bug. ***

Comment 3 Charles Lopes 2005-11-28 18:15:20 UTC
So this will also fix the issue reported in #174382 with the hardcoded path to
SecurityPolicy on FC4 with non-modular X?


Comment 4 Tim Waugh 2005-11-28 18:23:51 UTC
That's why I marked it as a duplicate, yes.

Comment 5 Tim Waugh 2005-11-29 22:57:57 UTC
4.1.1-23 has a first attempt.  Only the xorg-x11-server package needs bundling,
which reduces the source RPM size by quite a lot.  Unfortunately, the Xvnc
program needs an X server tree to build in -- the SDK is not sufficient.

I haven't tried to get the extension module built yet, just the Xvnc binary.

Comment 6 Tim Waugh 2005-12-01 09:52:12 UTC
Okay, extension module built too.

Comment 7 Tim Waugh 2005-12-01 09:56:16 UTC
..except the Xvnc binary crashes as soon as you connect.  Joy.

Comment 8 Tim Waugh 2005-12-01 15:15:52 UTC
Okay, now it works and everything.

Comment 9 Tim Waugh 2005-12-01 16:12:10 UTC
*** Bug 174702 has been marked as a duplicate of this bug. ***

Comment 10 Tim Waugh 2005-12-01 17:09:40 UTC
*** Bug 174711 has been marked as a duplicate of this bug. ***

Comment 11 Alexandre Oliva 2005-12-04 01:43:13 UTC
Doesn't work on x86_64.  Having `Load "vnc"' in xorg.conf causes X to not
display anything at all on the screen.  Commenting that line out, it gets back
to work.  On i386, this works just fine.  This worked up to -22, I believe,
although I think I still needed a symlink in the new extensiosn dir to point to
the old one.

Comment 12 Tim Waugh 2005-12-04 10:56:43 UTC
The x86_64 problem is a separate bug report now: bug #174702.


Note You need to log in before you can comment on or make changes to this bug.