Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 172930 - Impress crash when opening a file
Summary: Impress crash when opening a file
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
: 173107 173108 (view as bug list)
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-11-11 13:26 UTC by Nicolas Mailhot
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-11-12 20:04:36 UTC


Attachments (Terms of Use)

Description Nicolas Mailhot 2005-11-11 13:26:00 UTC
Description of problem:

When I try to open http://www.kroah.com/log/images/gkai-2.odp impress crashes
after a few seconds

Version-Release number of selected component (if applicable):

[root@rousalka packages]# rpm -qa | grep openoffice.org
openoffice.org-graphicfilter-2.0.1-0.138.3.2
openoffice.org-core-2.0.1-0.138.3.2
openoffice.org-math-2.0.1-0.138.3.2
openoffice.org-calc-2.0.1-0.138.3.2
openoffice.org-langpack-es-2.0.1-0.138.3.2
openoffice.org-writer-2.0.1-0.138.3.2
openoffice.org-draw-2.0.1-0.138.3.2
openoffice.org-langpack-fr-2.0.1-0.138.3.2
openoffice.org-xsltfilter-2.0.1-0.138.3.2
openoffice.org-langpack-ru-2.0.1-0.138.3.2
openoffice.org-impress-2.0.1-0.138.3.2

How reproducible:

Always

Steps to Reproduce:
1. Load the presentation
2. Wait 5s
  
Actual results:

0xf68c78a5: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e8a5
0xf68c80a8: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1f0a8
0xffffe500:  + 0x500 (__kernel_sigreturn + 0x0)
0x47f1820: /usr/lib/libicuuc.so.34 + 0x9f820
(icu_3_4::RuleBasedBreakIterator::RuleBasedBreakIterator(UDataMemory*,
UErrorCode&) + 0x56)
0xf119599d: /usr/lib/openoffice.org2.0/program/i18npool.uno.so + 0x4299d
0xf1196087: /usr/lib/openoffice.org2.0/program/i18npool.uno.so + 0x43087
0xf1192f2b: /usr/lib/openoffice.org2.0/program/i18npool.uno.so + 0x3ff2b
0xf75a33ed: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x27c3ed
0xf75a7755: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x280755
0xf75a787e: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x28087e
0xf7588cca: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x261cca
(EditEngine::IsTextPos(Point const&, unsigned short) + 0x96)
0xf75cdc97: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x2a6c97
(Outliner::IsTextPos(Point const&, unsigned short, unsigned char*) + 0x35)
0xf75cdd49: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x2a6d49
(Outliner::IsTextPos(Point const&, unsigned short) + 0x21)
0xf77cde65: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x4a6e65
(SdrTextObj::CheckHit(Point const&, unsigned short, SetOfByte const*) const + 0x3c9)
0xf77d7574: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x4b0574
(SdrRectObj::ImpCheckHit(Point const&, unsigned short, SetOfByte const*, int,
int) const + 0x3bc)
0xf77d75de: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x4b05de
(SdrRectObj::CheckHit(Point const&, unsigned short, SetOfByte const*) const + 0x26)
0xf7ca9e1e: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0xc6e1e
0xf7d2de4a: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x14ae4a
0xf7d2e537: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x14b537
0xf7d2dd1c: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x14ad1c
0xf7d30b2a: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x14db2a
0xf7cad719: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0xca719
0xf7cc02ac: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0xdd2ac
0xf7cb6ea4: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0xd3ea4
0xf727b664: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1d3664
0xf727cd49: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1d4d49
0xf727baf1: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1d3af1
0xf5685eae: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x28eae
0xf5682fab: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x25fab
0x41a30cc: /usr/lib/libgtk-x11-2.0.so.0 + 0x1160cc
0xa85bd8: /usr/lib/libgobject-2.0.so.0 + 0x8bd8 (g_closure_invoke + 0x11e)
0xa94213: /usr/lib/libgobject-2.0.so.0 + 0x17213
0xa955c3: /usr/lib/libgobject-2.0.so.0 + 0x185c3 (g_signal_emit_valist + 0x41e)
0xa95bc3: /usr/lib/libgobject-2.0.so.0 + 0x18bc3 (g_signal_emit + 0x29)
0x42854ff: /usr/lib/libgtk-x11-2.0.so.0 + 0x1f84ff
0x41a1807: /usr/lib/libgtk-x11-2.0.so.0 + 0x114807 (gtk_propagate_event + 0xc1)
0x41a1c40: /usr/lib/libgtk-x11-2.0.so.0 + 0x114c40 (gtk_main_do_event + 0x325)
0x9a56f3: /usr/lib/libgdk-x11-2.0.so.0 + 0x3e6f3
0x89aa50: /usr/lib/libglib-2.0.so.0 + 0x24a50 (g_main_context_dispatch + 0x1dc)
0x89da66: /usr/lib/libglib-2.0.so.0 + 0x27a66
0x89df48: /usr/lib/libglib-2.0.so.0 + 0x27f48 (g_main_context_iteration + 0x66)
0xf5675f23: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x18f23
0xf562f852: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x46852
(X11SalInstance::Yield(unsigned char) + 0x28)
0xf712916c: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8116c
(Application::Yield() + 0x48)
0xf71291a2: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x811a2
(Application::Execute() + 0x26)
0xf7fd68ba: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x248ba
(desktop::Desktop::Main() + 0x15b0)
0xf712e567: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x86567
0xf712e617: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x86617
(SVMain() + 0x29)
0xf7fce15f: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1c15f (sal_main
+ 0x57)
0xf7fce1ab: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1c1ab (main + 0x27)
0x2fd50f: /lib/libc.so.6 + 0x1550f (__libc_start_main + 0xdf)
0x80484c5: /usr/lib/openoffice.org2.0/program/simpress.bin + 0x4c5

Comment 1 Caolan McNamara 2005-11-11 14:34:37 UTC
should be ok in next respin.

Comment 2 Nicolas Mailhot 2005-11-12 20:04:36 UTC
seems fixed

Comment 3 Caolan McNamara 2005-11-14 09:01:19 UTC
*** Bug 173107 has been marked as a duplicate of this bug. ***

Comment 4 Caolan McNamara 2005-11-14 09:02:06 UTC
*** Bug 173108 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.