Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 172884 - Missing PCI ID for Sony VAIO graphics card (i915)
Summary: Missing PCI ID for Sony VAIO graphics card (i915)
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
: 172556 (view as bug list)
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-11-10 20:52 UTC by Chris Lee
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-03 13:34:16 UTC


Attachments (Terms of Use)

Description Chris Lee 2005-11-10 20:52:47 UTC
Description of problem:

Missing PCI ID for an Intel 915-based graphics card on a Sony VAIO laptop.

Version-Release number of selected component (if applicable): hwdata-0.158.3-1

Additional info: The card works fine with the i810 driver in X.org if I manually
configure it, but the installer chooses VESA because the system doesn't realize
which driver the card should use.

The card reports these PCI IDs:


VGA compatible controller
   00:02.0 Class 0300: 8086:2592 (rev 03)
   [Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller]

Display controller
   00:02.1 Class 0380: 8086:2792 (rev 03)
   [Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller]

Comment 1 Bill Nottingham 2005-11-10 21:11:32 UTC
Odd. See the comments about the driver in 172556.

Comment 2 Bill Nottingham 2005-11-10 21:11:52 UTC
*** Bug 172556 has been marked as a duplicate of this bug. ***

Comment 3 Thomas M Steenholdt 2005-11-11 08:51:28 UTC
According to mharris, FC5 (devel) CVS was missing a few patches in the .spec
file for xorg (one of them being backported support for 915GM and others). They
have been added in xorg-x11-6.8.2-62 that is set to hit rawhide today...

Until the, it can be found under
ftp://people.redhat.com/mharris/testing/unstable/xorg-x11/

It fixes the issue on my system!

Now we just have to wait for anaconda to be rebuilt on the fixed release and I
guess my installer issue will disappear as well.



Comment 4 Jeremy Katz 2006-01-29 19:55:00 UTC
Instead of static lists in hwdata, these should be moving to files included with
each driver package.

Comment 5 Mike A. Harris 2006-02-03 13:34:16 UTC
Fixed in xorg-x11-drv-i810-1.4.1.3-2


Note You need to log in before you can comment on or make changes to this bug.