Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 172827 - Error informing the kernel about modifications to partition /dev/hdc2 - Device or resource busy. This means Linux won't know about any changes you made to /dev/hdc2 until you reboot - so you shouldn't mount it or use it in any way before rebooting.
Summary: Error informing the kernel about modifications to partition /dev/hdc2 - Devic...
Keywords:
Status: CLOSED DUPLICATE of bug 160693
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-11-10 03:03 UTC by manishr
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-11-10 14:59:41 UTC


Attachments (Terms of Use)
It is the bug report that the installer prompted to save to floppy. (deleted)
2005-11-10 03:03 UTC, manishr
no flags Details

Description manishr 2005-11-10 03:03:00 UTC
Description of problem:
On first trying to install FC4 the anaconda crashed, prompting a bug report file
to be saved to floppy  and a message stating that this may be a bug - This
happened when trying to the disk partitions. Initially FC4 wouldn't accept the
default partitions option then it did and promptly crashed.

After re-booting, the installation went smoothly. 

Version-Release number of selected component (if applicable):


How reproducible:
Sorry haven't tried to reproduce it. Attached file may be of help.

Steps to Reproduce:
1. The following may cause the bug to be re-produced.

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 1137, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 244, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 873, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 174, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 242, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 579, in turnOnFilesystems
    diskset.savePartitions ()
  File "/usr/lib/anaconda/partedUtils.py", line 726, in savePartitions
    disk.commit()




2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 manishr 2005-11-10 03:03:01 UTC
Created attachment 120871 [details]
It is the bug report that the installer prompted to save to floppy.

Comment 2 Chris Lumens 2005-11-10 14:59:41 UTC

*** This bug has been marked as a duplicate of 160693 ***


Note You need to log in before you can comment on or make changes to this bug.