Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 172680 - Filters do not work
Summary: Filters do not work
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC6Target FC6Desktop
TreeView+ depends on / blocked
 
Reported: 2005-11-08 10:22 UTC by Need Real Name
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-07-30 05:07:19 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 323940 None None None Never

Description Need Real Name 2005-11-08 10:22:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Epiphany/1.6.5

Description of problem:
Filters on mail from an Exchange server, using Connector, do not work.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
x

Additional info:

Comment 1 Need Real Name 2005-12-01 15:10:07 UTC
The filters *do* work, but they are disabled my default.
Maybe show an error if a new filter is created when the option is off?

Comment 2 Dave Malcolm 2005-12-01 18:56:18 UTC
Good idea.

How about a warning dialog of this form after the filter is created:

+-----------------------------------------------------+
| You need to enable filtering on the "$ACCOUNT_NAME" |
| account for this filter to take effect.             |
|                                                     |
| [ ] Don't show this warning in future               |
|                       [Close]    [Enable Filtering] |
+-----------------------------------------------------+


Comment 3 Need Real Name 2005-12-02 07:11:24 UTC
Looks good to me!

Comment 5 Dave Malcolm 2005-12-13 00:25:59 UTC
I filed this upstream bug to cover this:
http://bugzilla.gnome.org/show_bug.cgi?id=323940

Comment 7 Matthias Clasen 2006-07-06 21:56:36 UTC
Add to FC6Destop tracker

Comment 8 Matthew Barnes 2006-07-30 05:07:19 UTC
Further discussion over whether or not filters ought to be enabled by default
when setting up an account should occur in the upstream bug report.

Resolving this as NOTABUG because:
1) The original problem description is not accurate.
2) Subsequent discussion is about a proposed enhancement.
3) In my judgement, this should not block Fedora Core 6.


Note You need to log in before you can comment on or make changes to this bug.