Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 172655 - cpuspeed needs some doc
Summary: cpuspeed needs some doc
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: cpuspeed
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jarod Wilson
QA Contact:
URL:
Whiteboard:
: 177562 (view as bug list)
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-11-07 22:32 UTC by Nicolas Mailhot
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-09 16:32:40 UTC


Attachments (Terms of Use)
dmesg (deleted)
2005-11-07 22:34 UTC, Nicolas Mailhot
no flags Details
lspci (deleted)
2005-11-07 22:35 UTC, Nicolas Mailhot
no flags Details

Description Nicolas Mailhot 2005-11-07 22:32:12 UTC
Description of problem:

On this system cpuspeed starts but crashes at once :

[root@rousalka nim]# /etc/init.d/cpuspeed start
Démarrage de cpuspeed :                                    [  OK  ]
[root@rousalka nim]# /etc/init.d/cpuspeed status
cpuspeed est mort mais subsys est verrouillé

Probably because the default parameters are
OPTS="$OPTS -t /proc/acpi/thermal_zone/*/temperature 75"

but there is no thermal zone on this system


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Nicolas Mailhot 2005-11-07 22:32:36 UTC
[root@rousalka xorg]# rpm -q cpuspeed kernel
cpuspeed-1.2.1-1.23
kernel-2.6.14-1.1649_FC5


Comment 2 Nicolas Mailhot 2005-11-07 22:34:15 UTC
Created attachment 120796 [details]
dmesg

Comment 3 Nicolas Mailhot 2005-11-07 22:35:01 UTC
Created attachment 120797 [details]
lspci

Comment 4 Nicolas Mailhot 2005-11-07 22:35:32 UTC
[root@rousalka nim]# find /proc/acpi/
/proc/acpi/
/proc/acpi/video
/proc/acpi/button
/proc/acpi/button/power
/proc/acpi/button/power/PWRB
/proc/acpi/button/power/PWRB/info
/proc/acpi/button/power/PWRF
/proc/acpi/button/power/PWRF/info
/proc/acpi/battery
/proc/acpi/ac_adapter
/proc/acpi/wakeup
/proc/acpi/alarm
/proc/acpi/thermal_zone
/proc/acpi/processor
/proc/acpi/processor/CPU1
/proc/acpi/processor/CPU1/power
/proc/acpi/processor/CPU1/limit
/proc/acpi/processor/CPU1/throttling
/proc/acpi/processor/CPU1/info
/proc/acpi/processor/CPU0
/proc/acpi/processor/CPU0/power
/proc/acpi/processor/CPU0/limit
/proc/acpi/processor/CPU0/throttling
/proc/acpi/processor/CPU0/info
/proc/acpi/fan
/proc/acpi/event
/proc/acpi/fadt
/proc/acpi/dsdt
/proc/acpi/info
/proc/acpi/power_resource
/proc/acpi/embedded_controller


Comment 5 Nicolas Mailhot 2005-11-07 22:36:00 UTC
Gigabyte GA-K8N Ultra-9 motherboard
(http://www.giga-byte.com/MotherBoard/Products/Products_GA-K8N%
20Ultra-9.htm)

Comment 6 Nicolas Mailhot 2005-11-07 22:39:15 UTC
(would probably be easier if there was some doc in the package in the first
place so I would know what the black magic options actually mean)

Comment 7 Nicolas Mailhot 2005-11-07 22:41:00 UTC
The system is able to change speed :

powernow-k8: Found 1 AMD Athlon 64 / Opteron processors (version 1.50.4)
powernow-k8:    0 : fid 0xe (2200 MHz), vid 0x6 (1400 mV)
powernow-k8:    1 : fid 0x2 (1000 MHz), vid 0x12 (1100 mV)

(cpufreq-selector works)

Comment 8 Nicolas Mailhot 2005-11-15 21:03:11 UTC
still crashing

Comment 9 Dave Jones 2005-11-28 19:21:16 UTC
I'm puzzled. The OPTS line is commented out in the cpuspeed.conf as shipped in
the rpm, so it shouldn't be trying to use it.


Comment 10 Dave Jones 2005-11-28 19:23:09 UTC
ah, I babelfish'd the error msg you get, and it makes a bit more sense.

the thermal_zone is unrelated, its a problem with /var/lock/subsys/cpuspeed


Comment 11 Nicolas Mailhot 2005-11-28 21:44:53 UTC
I probably commented out the line when editing the file to set powernow-k8 (or
maybe it was this way at the time, don't remember). Then noticed cpuspeed was
silently crashing a month later. Commenting it again cpuspeed no longuer crashes
 (/var/lock/subsys/cpuspeed is the lock leftover after a crash, this is the
standard error message when a service crashed)

I'd probably have found the problem myself if cpuspeed options where documented
somewhere. As it was I could only rely on the file comments, and since I wanted
thermal management I uncommented the wrong line (is there a way to do thermal
management without acpi zones ? This system has working temperature sensors)

So the two problems are :
- cpuspeed is lacking doc, it hasn't got even a README
- when cpuspeed crashes the service still writes a green OK and there's no error
message anywhere

... and my memory is hopeless

Comment 12 Dave Jones 2005-11-28 22:10:13 UTC
thermal stuff without acpi is a bit of a nightmare, as you need chipset specific
drivers (basically lm-sensors), which isn't always reliable.

As for the lack of cpuspeed docs, there's nothing in the upstream tarball, as is
common with far too many other small projects.  There is another bugzilla open
on for cpuspeed docs iirc, but it's one of those things that there's always
something else more important to fix, so I never get around to it.

I'll look into why it thought it succeeded after the crash.



Comment 13 Nicolas Mailhot 2005-11-28 22:32:10 UTC
lm-sensors works fine here. Owing probably to the fact it's documented, so I
could figure how to make it work :)

Comment 14 Jarod Wilson 2007-01-08 16:39:48 UTC
cpuspeed --help is really about all there is. I'll work on converting that
output (along with some other bits) into a proper man page, time permitting...

Comment 15 Jarod Wilson 2007-01-08 16:40:35 UTC
*** Bug 177562 has been marked as a duplicate of this bug. ***

Comment 16 Jarod Wilson 2007-01-08 21:53:52 UTC
Okay, time permitted today. Pending rawhide build includes both documentation
files that are now in the upstream tarball and a conversion of cpuspeed --help
to a man page (along with some other bits added to it).

Comment 17 Nicolas Mailhot 2007-01-08 22:03:24 UTC
Thanks a lot, that's awesome!

Comment 18 Jarod Wilson 2007-01-09 16:32:40 UTC
Rawhide builds now have a man page and a few docs. Will push to FC5 and FC6 after they've baked in 
rawhide for a bit...


Note You need to log in before you can comment on or make changes to this bug.