Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 172643 - libusb: Remove .la file
Summary: libusb: Remove .la file
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libusb
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2005-11-07 21:00 UTC by Kjartan Maraas
Modified: 2013-07-02 23:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-06-01 11:25:36 UTC


Attachments (Terms of Use)

Description Kjartan Maraas 2005-11-07 21:00:21 UTC
Description of problem:

.la files aren't strictly needed on Linux and causes a lot of problems when
compiling since they hardcode absolute paths to dependent libraries.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Tim Waugh 2005-11-08 09:17:04 UTC
I don't see anything wrong in the libusb la file.

Comment 2 Rex Dieter 2006-05-11 13:03:41 UTC
Packaging Guidelines recommend exclusion of %{_libdir}/lib*.la files. 
Re-opening.  Please reconsider for future FC releases (ie, fc6+).

Comment 3 Jindrich Novy 2006-06-01 11:25:36 UTC
The .la files are now removed.


Note You need to log in before you can comment on or make changes to this bug.