Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 172628 - Remove .la file from freetype-devel
Summary: Remove .la file from freetype-devel
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: freetype
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Carl Worth
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2005-11-07 20:47 UTC by Kjartan Maraas
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-08-18 16:28:32 UTC


Attachments (Terms of Use)

Description Kjartan Maraas 2005-11-07 20:47:11 UTC
Description of problem:

.la files aren't strictly needed on Linux and causes a lot of problems when
compiling since they hardcode absolute paths to dependent libraries.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jesse Keating 2006-08-17 22:19:01 UTC
Built into rawhide w/out .a and .la files.

Comment 2 Dawid Gajownik 2006-08-18 14:02:18 UTC
You should pass "--disable-static" option to configure script instead of
removing *.a files. This will speed up building process.

Comment 3 Jesse Keating 2006-08-18 16:28:32 UTC
That doesn't always work, but I'll toss it into CVS anyway.

Comment 4 Takanori MATSUURA 2007-06-20 02:53:34 UTC
Sorry for the comment to already-closed bug.

The reporter requests to remove "only" .la file and not want to remove .a file.

Static library is sometimes required for building binary files which is compiled
with all libraries being linked statically.

So we should run configure script without "--disable-static" and remove .la file
manually.

BTW, I think that .la file is created properly now.  But I agree with the
comment #1.

Comment 5 Dawid Gajownik 2007-06-20 15:29:10 UTC
(In reply to comment #4)
> So we should run configure script without "--disable-static" and remove .la file
> manually.

No, we should not. Current behavior is correct with packaging guidelines →
http://fedoraproject.org/wiki/Packaging/Guidelines#StaticLibraries


Comment 6 Takanori MATSUURA 2007-06-21 00:44:35 UTC
(In reply to comment #5)
OK. I confirmed.

Sorry for SPAM.


Note You need to log in before you can comment on or make changes to this bug.