Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 171884 - First ls always return an empty list
Summary: First ls always return an empty list
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: lftp
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-10-27 13:42 UTC by Nicolas Mailhot
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-11-23 21:46:46 UTC


Attachments (Terms of Use)

Description Nicolas Mailhot 2005-10-27 13:42:27 UTC
Description of problem:

When I do an ls in lftp the first ls always return immediatly with an empty
listing. I have to repeat the command to get a result

Version-Release number of selected component (if applicable):

lftp-3.3.2-1

How reproducible:

Always
(but maybe it's my ISP playing tricks with their transparent proxy)

Comment 1 Michal Jaegermann 2005-10-29 19:24:24 UTC
> (but maybe it's my ISP playing tricks with their transparent proxy)
I doubt it.  I have never seen that before but now I noticed that same thing.
Also hitting the same sites with a web browser shows directories all right.

But it looks like that it is a protocol dependent, i.e. I am seeing that when
using http but not ftp, and it also seem to depend on a site; although when
it happens it does the same thing with repeated connections.  Watch:

$ lftp http://download.fedora.redhat.com/pub/fedora/linux/
cd ok, cwd=/pub/fedora/linux
lftp download.fedora.redhat.com:/pub/fedora/linux> dir
lftp download.fedora.redhat.com:/pub/fedora/linux> dir
drwxr-xr-x  --  /
drwxr-xr-x  --  ..
drwxr-xr-x            -  2005-06-09 12:40  core
drwxr-xr-x            -  2005-07-29 13:05  extras

OTOH when trying ftp maybe I was "lucky" and did not run into connections
on which this happens?  I did not attempt a very systematic survey of protocols
and servers but http URL on which I am always getting directory on the first
try is, for example, http://mirrors.cat.pdx.edu/.  An idea that an observed
behaviour may depend on a directory level looks like dismissed by an
http://download.fedora.redhat.com/ counterexample where I have again call
'dir' twice.


Comment 2 Nicolas Mailhot 2005-10-29 20:52:04 UTC
I almost never do ftp nowadays, and I obviously use
http://download.fedora.redhat.com/ often, but I think I saw the same thing on
livna for example.

Anyway, nice to have a second confirmation - I only suspected my ISP because the
bug is so big I'm surprised I was the first to report it

Comment 3 Nicolas Mailhot 2005-11-11 16:16:26 UTC
Generally speaking, the latest rawhide x86_64 lftp binary is proving buggy as
hell and underwhelming

Comment 4 Jason Vas Dias 2005-11-11 17:29:23 UTC
Sorry about this. We just integrate the latest lftp release (which seems to
change every couple of weeks) into the Fedora build unchanged, and do some
basic tests, which did not expose this problem. The last two lftp releases 
(3.3.1, 3.3.2) were the only ones for over a year to cause any problems. 
I've now built the new lftp-3.3.3-1 release into FC-5/Rawhide, which is also
available from:
    http://people.redhat.com/~jvdias/lftp/
Please try out this version and let me know of any issues - thanks.
 

Comment 5 Nicolas Mailhot 2005-11-11 18:05:05 UTC
lftp-3.3.3-1.x86_64.rpm does not seem to exhibit this problem
The test was rather easy - http://people.redhat.com/~jvdias/lftp/ exhibited this bug

Will let you know if I find a problem using this version

Comment 6 Nicolas Mailhot 2005-11-23 20:34:39 UTC
After ten days of testing I have nothing bad to say about
lftp-3.3.3-1.x86_64.rpm - you should should it to rawhide

Comment 7 Jason Vas Dias 2005-11-23 21:31:08 UTC
As stated in Comment #4, lftp-3.3.3-1 has been in Rawhide (and now FC-5test1)
since 2005-11-11 .


Comment 8 Nicolas Mailhot 2005-11-23 21:46:46 UTC
Ok, closing then


Note You need to log in before you can comment on or make changes to this bug.