Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 171717 - No preconfigured yum repo for debug packages
Summary: No preconfigured yum repo for debug packages
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-release
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-10-25 15:56 UTC by Charles R. Anderson
Modified: 2013-01-10 01:19 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-24 01:51:29 UTC


Attachments (Terms of Use)

Description Charles R. Anderson 2005-10-25 15:56:05 UTC
Description of problem:

There is no preconfigured .repo file that points to the debug/ packages in the
base distro:

http://download.fedora.redhat.com/pub/fedora/linux/core/$releasever/$basearch/debug/

However, fedora-updates.repo and fedora-updates-testing.repo are sufficient for
accessing the debuginfo packages in their respective repositories, because the
repodata there references the debug/ subdirectory, precluding the need for
separate fedora-updates-debug.repo etc. files.

Version-Release number of selected component (if applicable):
4-2

How reproducible:
always

Expected results:

There should be a preconfigured .repo file to access the base distro debuginfo
packages, or the directory layout should be changed to allow the base repodata
to reference the debuginfo packages.  This repo could be enabled by default
(just like it effectively is for updates and updates-testing) because by default
 users will not have any debuginfo packages installed.

Comment 1 Warren Togami 2005-10-25 18:01:12 UTC
I'm hoping that we ship by default some way to point debuginfo at one
repository, and regular packages at another.  Often mirrors don't want to
download the debuginfo packages because they are incredibly large and not often
useful.  It would then be useful to have debuginfo available from the main
mirrors normally, but regular packages can be grabbed from your nearest custom
configured mirror.

Comment 2 Jesse Keating 2006-01-24 01:51:29 UTC
In the development tree the debug/ directory is within the main arch directory,
thus included in the createrepo run.  Same goes for the FC5 test releases.


Note You need to log in before you can comment on or make changes to this bug.