Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 171677 (EverlovePR) - Installer execption when loading Disk Druid or using Automatically partition
Summary: Installer execption when loading Disk Druid or using Automatically partition
Keywords:
Status: CLOSED DUPLICATE of bug 161877
Alias: EverlovePR
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: powerpc
OS: Linux
medium
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-10-25 06:45 UTC by Everin Malpica
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-11-08 02:31:13 UTC


Attachments (Terms of Use)

Description Everin Malpica 2005-10-25 06:45:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Description of problem:
There's an unhandled exeption that cancel the installation, when loading Disk Druid or using Automatically partition.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Re-start system holding the C key
2. type linux to boot from the linux CD (I also try linux text for text instalaltion)
3. Make default installation and the instalation stop runing Disk Druid or Automatically partition

Actual Results:  Installation aborted, now system without any OS.

Additional info:

Traceback (most recent call last):

File "/usr/bin/anaconda", line 1160, in ? intf .run(id, dispatch)
File "/usr/lib/anaconda/text.py", line 496, in run dispatch.gotoNext() 
File "/usr/lib/anaconda/dispatch.py", line 174, in gotoNext self.moveStep() 
      rc = apply(func, self.bindArgs(args))
File "/usr/lib/anaconda/partitioning.py", line 54, in partitionObjectsInitialize partitions.setFromDisk(Diskset)
File "/usr/lib/anaconda/partitions.py", line 108, in setFomDisk
   ptype=partedUtils.get_partition_file_system_type(part)
File "/usr/lib/anaconda/partedUtils.py", line 140, in get_partition_file_system_type
   elif (part.get_flag(parted.PARTITION_BOOT) == 1 and
AttributeError: 'NoneType' object has no attribute 'name'

Comment 1 Jeremy Katz 2005-11-08 02:31:13 UTC

*** This bug has been marked as a duplicate of 161877 ***


Note You need to log in before you can comment on or make changes to this bug.