Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 171643 - repomd error after up2date
Summary: repomd error after up2date
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Bryan Kearney
QA Contact: Beth Nackashi
URL:
Whiteboard:
: 173492 (view as bug list)
Depends On:
Blocks: RHEL3U8CanFix
TreeView+ depends on / blocked
 
Reported: 2005-10-24 17:26 UTC by Bastien Nocera
Modified: 2013-01-10 08:50 UTC (History)
3 users (show)

Fixed In Version: RHBA-2006-0465
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-07-20 15:14:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0465 normal SHIPPED_LIVE up2date bug fix update 2006-07-19 20:50:00 UTC

Comment 1 Bastien Nocera 2005-10-24 17:28:35 UTC
repoDirector.py, initRepoDirector() contains the following block:

    # bz #158256 (allow up2date to continue if yum repomd support isnt found)
    try:
        from repoBackends import repomdRepo
        repomdRepo.register(rd)
    except ImportError:
        log = up2dateLog.initLog()
        log.log_me("Unable to import repomd support so repomd support will not
be available")

Since users generally don't have yum installed on RHEL3, there is no yum python
module and users are seeing this message every time up2date is started.

Comment 6 Fanny Augustin 2006-04-11 00:32:32 UTC
Blocking rhnupr4u4 and rhnupr3u8 to track the progress of the release

Comment 7 Fanny Augustin 2006-04-13 19:35:48 UTC
Moving bugs to the CanFix List

Comment 11 Fanny Augustin 2006-05-09 19:38:28 UTC
This bug has been fixed in this release

Comment 12 Beth Nackashi 2006-05-15 20:32:51 UTC
The two files changed to fix this bug were in /usr/share/rhn/up2date_client:

sourcesConfig.py: Added a configHasRepomd() method. when supplied with a list
    of sources it will return 1 or 0 depending on if at least one of the sources
    is a repomd source.

repoDirector.py: Load the list of sources and only try to import the repomd
    backend if at least one of the sources is a repomd source.



Comment 13 Beth Nackashi 2006-05-15 20:58:26 UTC
How to reproduce the problem:
Install an old version of up2date on an x86_64 box, and run up2date --showall
and tail -f /var/log/up2date:

[Mon May 15 16:56:43 2006] up2date updating login info
[Mon May 15 16:56:43 2006] up2date logging into up2date server
[Mon May 15 16:56:44 2006] up2date successfully retrieved authentication token
from up2date server
[Mon May 15 16:56:44 2006] up2date availablePackageList from network
[Mon May 15 16:56:44 2006] up2date Unable to import repomd support so repomd
support will not be available


Verified the fix on i386 and ia64 using up2date-4.4.69-8
(requires rhnlib-1.8.7-1):

[Mon May 15 16:48:18 2006] up2date updating login info
[Mon May 15 16:48:18 2006] up2date logging into up2date server
[Mon May 15 16:48:19 2006] up2date successfully retrieved authentication token
from up2date server
[Mon May 15 16:48:19 2006] up2date availablePackageList from network


[Mon May 15 16:57:03 2006] up2date updating login info
[Mon May 15 16:57:03 2006] up2date logging into up2date server
[Mon May 15 16:57:03 2006] up2date successfully retrieved authentication token
from up2date server
[Mon May 15 16:57:03 2006] up2date availablePackageList from network

Seems it doesn't really matter if there is yum repo stuff in
/etc/sysconfig/rhn/sources or not, the repomd error message no longer appears in
/var/log/up2date.

Regression tested the sources file:
up2date VMware-console says "package not found" when no yum repos are listed in
sources.

up2date VMware-console gives a different error message (404) when yum repos are
listed in sources.  This at least proves the yum stuff is being read from the
sources file and no repomd errors are showing up in /var/log/up2date.

Comment 14 Beth Nackashi 2006-05-15 21:06:03 UTC
And I tried up2date VMware-console via yum again and it worked.  No 404.

Comment 15 Stuart Ellis 2006-05-30 08:33:25 UTC
I'm seeing the same error about repomd support in up2date logs on RHEL 3 Update
7 systems; there is an open bug for this as 173492. Would it be possible to
update the RHEL 3 up2date with this fix?

Comment 16 James Bowes 2006-06-01 13:40:59 UTC
*** Bug 173492 has been marked as a duplicate of this bug. ***

Comment 17 James Bowes 2006-06-01 13:43:22 UTC
(In reply to comment #15)
> I'm seeing the same error about repomd support in up2date logs on RHEL 3 Update
> 7 systems; there is an open bug for this as 173492. Would it be possible to
> update the RHEL 3 up2date with this fix?

This fix should be in the next updates for RHEL 3 and RHEL 4.

Comment 19 Red Hat Bugzilla 2006-07-20 15:14:56 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0465.html



Note You need to log in before you can comment on or make changes to this bug.