Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 171405 - Netdump server does not receive packets when bound to an alias address
Summary: Netdump server does not receive packets when bound to an alias address
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: netdump
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Graf
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 178807 RHEL3U8CanFix
TreeView+ depends on / blocked
 
Reported: 2005-10-21 15:50 UTC by Jeff Moyer
Modified: 2014-06-18 08:28 UTC (History)
5 users (show)

Fixed In Version: RHBA-2006-0462
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-07-20 14:30:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0462 normal SHIPPED_LIVE netdump bug fix update 2006-07-19 18:32:00 UTC

Description Jeff Moyer 2005-10-21 15:50:29 UTC
Description of problem:

The netdump-server is running on a machine with an eth card that has a few IP
addresses, all but one of which are assigned via interface aliases.  All these
IP addresses are on the same logical subnet (vlan). The netdump clients all
point to an IP that is on one of the IPs that is associated with and interface
alias.  I found through network sniffing on the server side that the netdump
client sends its request to IP A, and while the server *does* receive the
request and answer back, it answers from the main non-aliased IP B.

Talking to A and hearing back from B apparently doesn't fly with the netdumping
client.  When I change the client to point at IP B... it works just fine.

From my understanding of it, the netdump-server would in fact answer back to the
client from an aliased IP A if it was bound specifically to that IP.  Is there
a way to get the netdump-server to bind to a specific IP address?  This is an
option for most other network services... but I don't see any mention of that in
the netdump-server man page or init script.



Version-Release number of selected component (if applicable):
netdump-0.7.7-2
netdump-server-0.7.7-2

How reproducible:
100%

Steps to Reproduce:
1. Configure a netdump server with multiple addresses via ethernet aliases.  All
addresses should be on the same subnet.
2. Configure the netdump client to dump to one of the aliased addresses on the
server.
3. Initiate a netdump.  The return packets will come from a different IP
address, and so the netdump client will discard them.
  
Actual results:
The netdump server will timeout when trying to handshake with the client.

Expected results:
A full netdump should be taken.

Additional info:
This was originally discussed in bz #145476.  This bugzilla was created due to
confusion in that bugzilla.  Too many issues were being debugged.

Comment 1 Thomas Graf 2006-01-24 15:18:54 UTC
Fix commited in version 0.7.16-1

Comment 4 Bob Johnson 2006-04-11 16:42:37 UTC
This issue is on Red Hat Engineering's list of planned work items 
for the upcoming Red Hat Enterprise Linux 4.4 release.  Engineering 
resources have been assigned and barring unforeseen circumstances, Red 
Hat intends to include this item in the 4.4 release.

Comment 15 Red Hat Bugzilla 2006-07-20 14:30:50 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0462.html



Note You need to log in before you can comment on or make changes to this bug.