Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 171166 - gam_server restarting many times a second
Summary: gam_server restarting many times a second
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gamin
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2005-10-18 23:25 UTC by Dave Malcolm
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-09-06 09:44:35 UTC


Attachments (Terms of Use)

Description Dave Malcolm 2005-10-18 23:25:40 UTC
Description of problem:
Running rawhide(ish), seeing a problem where CPU usage becomes 70-80%, but
looking in top shows no obvious culprit.

On investigation it turns out that gam_server is restarting repeatedly,
occasionally visible for a fraction of a second in top or in gnome-system-monitor

Version-Release number of selected component (if applicable):
gamin-0.1.6-3
kernel-2.6.13-1.1601_FC5

How reproducible:
Don't know.  Seems to happen perhaps every few hours on my workstation; killing
off gnome-settings-daemon seems to help.

Here's a link for my own reference to the debug notes on gamin:
http://www.gnome.org/~veillard/gamin/debug.html

What process is responsible for restarting gam_server?  I'm happy to try to
track this down myself, but it's so transient that it's difficult to debug.  Thanks.

Comment 1 Alexander Larsson 2006-08-14 12:24:42 UTC
Any app that uses gamin will cause it to restart when its needed. However, it
shouldn't restart, because it shouldn't exit in the first place. Need to figure
out why its exiting.


Comment 2 Eric Hopper 2006-08-14 17:22:22 UTC
Of course, the process that continually restarts gam_server needs to throttle
itself a bit as well.  If the first few restarts fail, put in a greater interval
before it'll try again until its down to re-trying only once every 5-10 seconds
or so.

Defense in depth.  A bug that causes gam_server to crash all the time should be,
as much as possible, prevented from having a seriously negative effect on the
system as a whole.


Comment 3 Alexander Larsson 2006-08-16 06:48:05 UTC
I had a quick look at preventing excessive looping. Its not trivial, the
restarting happens an multiple levels.

Comment 4 Eric Hopper 2006-08-16 16:54:27 UTC
This is a big change, but perhaps gam_server could be configured to be on DBus
instead.  Then you can have a watchdog daemon that makes sure it stays healthy,
and apps can communicate with it via DBus.

Comment 5 Matthias Clasen 2006-08-19 02:10:20 UTC
Noting that the original report is almost a year old, has anybody
seen this problem in recent times ?

Comment 6 Eric Hopper 2006-08-19 07:39:11 UTC
I've not seen that problem, just gam using up ridiculous amounts of memory.


Comment 7 Matthias Clasen 2006-08-19 14:29:08 UTC
Ok, lets move this of the blocker list then

Comment 8 Alexander Larsson 2006-09-06 09:44:35 UTC
Lots of gamin fixing in rawhide lately. Please open new bugs with details if you
get anything like this with gamin 0.1.7-6 or later.



Note You need to log in before you can comment on or make changes to this bug.