Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 170890 - NetworkManager-vpnc and SELinux problem returns
Summary: NetworkManager-vpnc and SELinux problem returns
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager-vpnc
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Denis Leroy
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-10-15 03:09 UTC by Martin C. Messer
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-10-05 17:54:19 UTC


Attachments (Terms of Use)

Description Martin C. Messer 2005-10-15 03:09:10 UTC
Description of problem:

Same symptoms as bug 163405. Using setenforce 0 allows the VPN connection to
continue without /var/log/messages error (see below).

Version-Release number of selected component (if applicable):

NetworkManager-0.4.1-5.cvs20051010
NetworkManager-vpnc-0.3-1

How reproducible:

Always

Actual results:

Oct 14 22:58:02 localhost NetworkManager: <WARNING>       (): VPN failed for
service 'org.freedesktop.NetworkManager.vpnc', signal 'ConnectFailed', with
message 'The VPN login failed because the VPN program could not connect to the
VPN server.'.

Expected results:

VPN connection (which happens with 'setenforce 0').

Additional info:

Comment 1 Martin C. Messer 2005-10-16 00:36:56 UTC
I failed to mention a key piece of info:

selinux-policy-targeted-1.27.1-2.3

Supposedly this problem was fixed with version 1.25.3-11 of that package. Not
sure if that means the bug is there or in NM.

Comment 2 Misha Kononov 2006-02-20 19:09:04 UTC
Still experiencing this bug. Also note that the bug persists with SELinux
running in passive mode, though not with it disabled. Also, the symptoms do not
occur when running the NetworkManager daemon in CLI with --no-daemon. 

Comment 3 Daniel Walsh 2006-03-04 15:31:09 UTC
Are you seeing any AVC messages in /var/log/audit/audit.log? or /var/log/messages?

Comment 4 Daniel Walsh 2006-03-08 16:55:07 UTC
This is not an SELinux problem at this point.

Comment 5 Denis Leroy 2006-09-28 23:36:35 UTC
Taking ownership.


Comment 6 Warren Togami 2007-10-05 17:54:19 UTC
This was fixed long ago.



Note You need to log in before you can comment on or make changes to this bug.