Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1704 - nfs servers does not validate hosts properly.
Summary: nfs servers does not validate hosts properly.
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: knfsd
Version: 6.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-03-23 20:47 UTC by Joseph Kotran
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-09-05 13:44:25 UTC


Attachments (Terms of Use)

Description Joseph Kotran 1999-03-23 20:47:17 UTC
The nfs server does not allow any client except the local
host to mount a nfs share when configured as follows:

/etc/exports:

/export/hostname1	*.domain.org
/mnt/cdrom		*.domain.org

/etc/nsswitch.conf:

hosts:	dns nis [NOTFOUND=return] files

It should allow mounts from clients that are in the
.domain.org DNS domain.  It does not allow any mounts.  If I
remove the restriction on DNS domain all clients may mount
the NFS shares.

Comment 1 Preston Brown 1999-03-26 21:36:59 UTC
Dave, can you verify this? I doubt it... Make sure you use knfsd.

Comment 2 Jeff Johnson 1999-09-05 13:44:59 UTC
I cannot reproduce this problem.


Note You need to log in before you can comment on or make changes to this bug.