Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 170364 - Installer crashes using kickstart with excluded packages
Summary: Installer crashes using kickstart with excluded packages
Keywords:
Status: CLOSED DUPLICATE of bug 160209
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-10-11 00:32 UTC by Bevan Bennett
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-11 01:59:13 UTC


Attachments (Terms of Use)
Anaconda generated kickstart that crashes (deleted)
2005-10-11 00:33 UTC, Bevan Bennett
no flags Details

Description Bevan Bennett 2005-10-11 00:32:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc3 Firefox/1.0.6

Description of problem:
I'm trying to get a desktop kickstart file up and running for FC4, but the installer kept crashing after "Reading Package Information" (complete error below). After testing, it appears that this occurs whenever the kickstart file specifies a specific package -not- to install (which, for example, the generated anaconda-ks.cfg from my manual install included).

File "/usr/bin/anaconda", line 1160 in ?
  intf.run(id, dispatch)
File "/usr/bin/anaconda/gui.py", line 770, in run
  self.icw.run(self.runres)
File "/usr/bin/anaconda/gui.py", line 1325, in run
  self.setup_window(runres)
File "/usr/bin/anaconda/gui.py", line 1314, in setup_window
  self.setScreen()
File "/usr/bin/anaconda/gui.py", line 1149, in setScreen
  (step, args) = self.dispatch.currentStep()
File "/usr/bin/anaconda/dispatch.py", line 279, in currentStep
  self.gotoNext()
File "/usr/bin/anaconda/dispatch.py", line 174, in gotoNext
  self.moveStep()
File "/usr/bin/anaconda/dispatch.py", line 242, in moveStep
  rc = apply(func, self.bindArgs(args))
File "/usr/bin/anaconda/packages.py", line 207, in readPackages
  id.instClass.setGroupSelection(grpset, intf)
File "/usr/bin/anaconda/kickstart.py", line 1559, in setGroupSelection
  pkgs = grpset.hdrlist.pkgnames[name]
KeyError: "

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create a kickstart file with the following %packages section

%packages
@ office
@ engineering-and-scientific
@ editors
@ emacs
@ gnome-software-development
@ text-internet
@ x-software-development
@ gnome-desktop
@ authoring-and-publishing
@ games
@ emacs
@ base-x
@ graphics
@ printing
@ admin-tools
@ development-tools
@ sound-and-video
@ graphical-internet
-evolution
tetex-xdvi
kernel-smp-devel
kernel-smp
grub
xfig
thunderbird
e2fsprogs
vim-X11
openoffice.org-javafilter
lvm2

2. Install using the kickstart file.
  

Actual Results:  The crash message cited above.

Expected Results:  The system should have installed without the evolution package.

Additional info:

The entire anaconda-generated kickstart from my manual install will be attached, it crashes unless all the package exclusion lines are removed from the kickstart file.

I can work around this for now by placing suitable "rpm -e package" commands in %post, but it's a waste of my time and bandwidth.

Comment 1 Bevan Bennett 2005-10-11 00:33:41 UTC
Created attachment 119790 [details]
Anaconda generated kickstart that crashes

Comment 2 Chris Lumens 2005-10-11 01:59:13 UTC

*** This bug has been marked as a duplicate of 160209 ***


Note You need to log in before you can comment on or make changes to this bug.