Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 170209 - First Installation process terminated in file formatting.
Summary: First Installation process terminated in file formatting.
Keywords:
Status: CLOSED DUPLICATE of bug 160693
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-10-09 02:54 UTC by ray
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-13 13:34:01 UTC


Attachments (Terms of Use)

Description ray 2005-10-09 02:54:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.1.4322)

Description of problem:
I've got a pc with OS windows 2000. I install the fedora core 4 the first time in a dvd then follow all instructions. I deleted all windows partition. When I click next then it will format the hdd to linux file system a window will appear and many bugs then it will need to be rebooted. after rebooting the same process i did and i completely install the fedora. so why it there is an error in first installation? why it can format the hdd in first installation? 

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:

Comment 1 Jeremy Katz 2005-10-11 16:17:31 UTC
Can you provide the complete traceback you received?

Comment 2 ray 2005-10-13 06:49:22 UTC
(In reply to comment #1)
> Can you provide the complete traceback you received?

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 1137, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 244, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 873, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 174, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 242, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 579, in turnOnFilesystems
    diskset.savePartitions ()
  File "/usr/lib/anaconda/partedUtils.py", line 726, in savePartitions
    disk.commit()
error: Error: Error informing the kernel about modifications to partition /dev/hda2
- Device or resource busy.  This means Linux won't know about any changes you made
to /dev/hda2 until you reboot - so you shouldn't mount it or use it in any way
before rebooting.

Local variables in innermost frame:
self: <partedUtils.DiskSet instance at 0xb7ade3cc>
disk: <PedDisk object at 0xb7eaebd8>

Comment 3 ray 2005-10-13 06:49:46 UTC
Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 1137, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 244, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 873, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 174, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 242, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 579, in turnOnFilesystems
    diskset.savePartitions ()
  File "/usr/lib/anaconda/partedUtils.py", line 726, in savePartitions
    disk.commit()
error: Error: Error informing the kernel about modifications to partition /dev/hda2
- Device or resource busy.  This means Linux won't know about any changes you made
to /dev/hda2 until you reboot - so you shouldn't mount it or use it in any way
before rebooting.

Local variables in innermost frame:
self: <partedUtils.DiskSet instance at 0xb7ade3cc>
disk: <PedDisk object at 0xb7eaebd8>

Comment 4 Chris Lumens 2005-10-13 13:34:01 UTC

*** This bug has been marked as a duplicate of 160693 ***


Note You need to log in before you can comment on or make changes to this bug.