Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1698653 - Overcloud deployment failed when compute nic config template without br-ex bridge
Summary: Overcloud deployment failed when compute nic config template without br-ex br...
Keywords:
Status: CLOSED DUPLICATE of bug 1694213
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: ---
Assignee: Emilien Macchi
QA Contact: Sasha Smolyak
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-10 21:19 UTC by Yuri Obshansky
Modified: 2019-04-11 14:19 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-11 14:19:03 UTC
Target Upstream Version:


Attachments (Terms of Use)
Compute node nic config template (deleted)
2019-04-10 21:20 UTC, Yuri Obshansky
no flags Details
ansible.log (deleted)
2019-04-10 21:24 UTC, Yuri Obshansky
no flags Details

Description Yuri Obshansky 2019-04-10 21:19:03 UTC
Description of problem:
Overcloud deployment failed when compute nic config template without br-ex bridge
with error:
        "Error: 'ovs-vsctl --timeout=5 set Bridge br-ex other-config:mac-table-size=50000' returned 1 instead of one of [0]",
        "Error: /Stage[main]/Ovn::Controller/Exec[br-ex]/returns: change from 'notrun' to ['0'] failed: 'ovs-vsctl --timeout=5 set Bridge br-ex other-config:mac-table-size=50000' returned 1 instead of one of [0]",

Spine-Leaf network topology

Compute nic config template will be attached

Version-Release number of selected component (if applicable):
Compose: RHOS_TRUNK-15.0-RHEL-8-20190403.n.3

openstack-tripleo-common-containers-10.6.1-0.20190404000356.3398bec.el8ost.noarch
python3-tripleoclient-heat-installer-11.3.1-0.20190403170353.73cc438.el8ost.noarch
openstack-tripleo-image-elements-10.3.1-0.20190325204940.253fe88.el8ost.noarch
ansible-tripleo-ipsec-9.0.1-0.20190220162047.f60ad6c.el8ost.noarch
ansible-role-tripleo-modify-image-1.0.1-0.20190402220346.012209a.el8ost.noarch
python3-tripleoclient-11.3.1-0.20190403170353.73cc438.el8ost.noarch
python3-tripleo-common-10.6.1-0.20190404000356.3398bec.el8ost.noarch
openstack-tripleo-validations-10.3.1-0.20190403171315.a4c40f2.el8ost.noarch
openstack-tripleo-common-10.6.1-0.20190404000356.3398bec.el8ost.noarch
openstack-tripleo-puppet-elements-10.2.1-0.20190327211339.0f6cacb.el8ost.noarch
openstack-tripleo-heat-templates-10.4.1-0.20190403221322.0d98720.el8ost.noarch
puppet-tripleo-10.3.1-0.20190403180925.81d7714.el8ost.noarch


How reproducible:


Steps to Reproduce:
1. Build virt env with Spine Leaf topology 
2. Install UC
3. Start deploy Overcloud

Actual results:
PLAY [External deployment Post Deploy tasks] ***********************************

PLAY RECAP *********************************************************************
overcloud-compute0-0       : ok=135  changed=51   unreachable=0    failed=1   
overcloud-compute1-0       : ok=137  changed=63   unreachable=0    failed=1   
overcloud-compute2-0       : ok=137  changed=63   unreachable=0    failed=1   
overcloud-controller0-0    : ok=230  changed=91   unreachable=0    failed=0   
overcloud-controller0-1    : ok=219  changed=88   unreachable=0    failed=0   
overcloud-controller0-2    : ok=219  changed=88   unreachable=0    failed=0   
undercloud                 : ok=11   changed=7    unreachable=0    failed=0   

Wednesday 10 April 2019  20:37:35 +0000 (0:00:00.170)       0:35:40.920 ******* 
=============================================================================== 

Ansible failed, check log at /var/lib/mistral/overcloud/ansible.log.
Exception occured while running the command
Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/tripleoclient/command.py", line 30, in run
    super(Command, self).run(parsed_args)
  File "/usr/lib/python3.6/site-packages/osc_lib/command/command.py", line 41, in run
    return super(Command, self).run(parsed_args)
  File "/usr/lib/python3.6/site-packages/cliff/command.py", line 184, in run
    return_code = self.take_action(parsed_args) or 0
  File "/usr/lib/python3.6/site-packages/tripleoclient/v1/overcloud_deploy.py", line 949, in take_action
    verbosity=self.app_args.verbose_level)
  File "/usr/lib/python3.6/site-packages/tripleoclient/workflows/deployment.py", line 327, in config_download
    raise exceptions.DeploymentError("Overcloud configuration failed.")
tripleoclient.exceptions.DeploymentError: Overcloud configuration failed.


Expected results:
Passed

Additional info:

Comment 1 Yuri Obshansky 2019-04-10 21:20:29 UTC
Created attachment 1554360 [details]
Compute node nic config template

Comment 2 Yuri Obshansky 2019-04-10 21:24:18 UTC
Created attachment 1554361 [details]
ansible.log

Comment 4 Bob Fournier 2019-04-11 14:19:03 UTC
As we already have a bug for this marking this as a duplicate.

*** This bug has been marked as a duplicate of bug 1694213 ***


Note You need to log in before you can comment on or make changes to this bug.