Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 169687 - gfs_fsck: ondisk and fsck bitmaps differ at block XXXXX: never fixed
Summary: gfs_fsck: ondisk and fsck bitmaps differ at block XXXXX: never fixed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: gfs
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Feist
QA Contact: GFS Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-10-01 04:51 UTC by Axel Thimm
Modified: 2010-01-12 03:07 UTC (History)
0 users

Fixed In Version: 6.1.2-0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-11-07 17:07:52 UTC


Attachments (Terms of Use)

Description Axel Thimm 2005-10-01 04:51:12 UTC
Description of problem:
Running gfs_fsck finds some differening bitmaps and gfs_fsck offers to fix them.
Even though answering yes to this offer a subsequent gfs_fsck run show the same
errors.

Version-Release number of selected component (if applicable):
GFS-6.1.0-0

How reproducible:
Always

Steps to Reproduce:
1.Manage to get differing bitmaps
2.Run gfs_fsck and answer y to all questions or run gfs_fsck -y
3.Do 2. again
  
Actual results:
The bitmaps still differ

Expected results:
The second run should be clean, or the errors maekred as non-recoverable.

Additional info:
I won't be able to do much further testing, as we are about to wipe the
filesystem and recreate it.

The gfs filesystem is not mounted by any cluster member during gfs_fsck.

Comment 1 Chris Feist 2005-11-07 17:07:52 UTC
I am unable to replicate and believe this bug has been fixed in the latest GFS
release (GFS-6.1.2-0.i386)

Comment 2 Axel Thimm 2005-11-08 10:12:53 UTC
I haven't since encountered it again, but OTOH I haven't managed to corrupt the
filesystem again. If I see it again, I'll reopen.

Is there any other information I should gather in this case?



Note You need to log in before you can comment on or make changes to this bug.