Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1696770 - [kube] unit test flake: TestUnsupportedVersion "KMS provider api version invalid is not supported, only v1beta1 is supported nower"
Summary: [kube] unit test flake: TestUnsupportedVersion "KMS provider api version inva...
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Auth
Version: 4.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.1.0
Assignee: Erica von Buelow
QA Contact: Chuan Yu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-05 15:19 UTC by Seth Jennings
Modified: 2019-04-15 21:01 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-15 21:01:28 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Seth Jennings 2019-04-05 15:19:03 UTC
https://openshift-gce-devel.appspot.com/build/origin-ci-test/pr-logs/pull/22486/pull-ci-openshift-origin-master-unit/4723

=== RUN   TestUnsupportedVersion
=== PAUSE TestUns ...
				
=== RUN   TestUnsupportedVersion
=== PAUSE TestUnsupportedVersion
=== CONT  TestUnsupportedVersion
--- FAIL: TestUnsupportedVersion (1.44s)
	grpc_service_unix_test.go:249: got err: failed get version from remote KMS provider: rpc error: code = DeadlineExceeded desc = context deadline exceededer, want: KMS provider api version invalid is not supported, only v1beta1 is supported nower

Comment 1 Jan Safranek 2019-04-08 07:49:23 UTC
Failed tests: github.com/openshift/origin/vendor/k8s.io/apiserver/pkg/storage/value/encrypt/envelope TestUnsupportedVersion 1.44s
	grpc_service_unix_test.go:249: got err: failed get version from remote KMS provider: rpc error: code = DeadlineExceeded desc = context deadline exceededer, want: KMS provider api version invalid is not supported, only v1beta1 is supported nower

'storage' in the path refers to database of API objects (=etcd), not persistent storage of application data (PV/PVC) ;-)

Comment 3 Erica von Buelow 2019-04-15 20:56:11 UTC
Is this still flaking? I am unclear over whether this is something we should prioritize.

Comment 4 Seth Jennings 2019-04-15 21:01:28 UTC
Nope, doesn't seem like it is a thing any more.  I didn't notice the DeadlineExceeded before.  This could have been an externality casing this.


Note You need to log in before you can comment on or make changes to this bug.