Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1696597 - log floods repeating constantly with read_lines_limit [NEEDINFO]
Summary: log floods repeating constantly with read_lines_limit
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.11.z
Assignee: Jeff Cantrill
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-05 08:25 UTC by Alberto Gonzalez de Dios
Modified: 2019-04-09 17:03 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-09 17:03:40 UTC
Target Upstream Version:
rmeggins: needinfo? (algonzal)


Attachments (Terms of Use)

Description Alberto Gonzalez de Dios 2019-04-05 08:25:56 UTC
Description of problem:
Fluentd log rate is limited with read_lines_limit (solved in BZ 1692694), but from time to time, there are log floods. 

Checking fluentd logs, there are some errors of "queue size exceeds limit":

2019-04-05 05:47:56 +0200 [warn]: emit transaction failed: error_class=Fluent::BufferQueueLimitError error="queue size exceeds limit" location="/usr/share/gems/gems/fluentd-0.12.43/lib/fluent/buffer.rb:204:in `block in emit'" tag="output_tag"

2019-04-05 05:53:58 +0200 [error]: Exception emitting record: queue size exceeds limit

Current fluentd conf

    .operations:
      read_lines_limit: 1

Version-Release number of selected component (if applicable):
3.11

Comment 7 Jeff Cantrill 2019-04-09 17:03:40 UTC
Closing as this is not a bug.  Fluent may require buffer tweaking as identified.


Note You need to log in before you can comment on or make changes to this bug.