Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1696497 - Request that Make Untility be included with GCC or CLANG
Summary: Request that Make Untility be included with GCC or CLANG
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution
Version: 30
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Josh Boyer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-05 01:39 UTC by Leslie Satenstein
Modified: 2019-04-13 04:13 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-12 19:04:33 UTC


Attachments (Terms of Use)

Description Leslie Satenstein 2019-04-05 01:39:45 UTC
Description of problem:

This is a request.

It is very frustrating to download some software development groups and then discover that the make utility is not included.  It becomes an extra sudo dnf install for make 

 



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Florian Weimer 2019-04-05 03:07:01 UTC
(In reply to Leslie Satenstein from comment #0)
> It is very frustrating to download some software development groups and then
> discover that the make utility is not included.

How do you download these software development groups?  Thanks.

Comment 2 Leslie Satenstein 2019-04-08 17:31:50 UTC
Actually, from the live ISO for workstation.  
I usually have to do a separate dnf install make 

I can't recall if KDE spin has the same problem.

gcc  hould have make included

Comment 3 Jonathan Wakely 2019-04-09 11:33:36 UTC
I disagree. Make is not necessary to use GCC, at all. Some people prefer to use other build systems such as ninja-build or meson.

Maybe the command you're looking for is: dnf group install "C Development Tools and Libraries"

This installs gcc, g++, make, binutils, gdb and several more:

Group: C Development Tools and Libraries
 Description: These tools include core development tools such as automake, gcc and debuggers.
 Mandatory Packages:
   autoconf
   automake
   binutils
   bison
   flex
   gcc
   gcc-c++
   gdb
   glibc-devel
   libtool
   make
   pkgconfig
   strace
 Default Packages:
   byacc
   ccache
   cscope
   ctags
   elfutils
   indent
   ltrace
   oprofile
   valgrind
 Optional Packages:
   ElectricFence
   astyle
   cbmc
   check
   cmake
   coan
   cproto
   elfinfo
   insight
   nasm
   pscan
   remake
   scons
   scorep
   splint
   trinity
   undertaker
   yasm
   zzuf

Comment 4 Jakub Jelinek 2019-04-09 11:39:25 UTC
Agreed, nothing in gcc requires make.

Comment 5 Leslie Satenstein 2019-04-10 21:30:22 UTC
Fedora is not a server installation. It is actually a Developer platform that serves multiple communities.
Make can be used for gcc, it can be used as to manage rsync type situations were dependencies are required.
It can be used for python builds and more.

It is narrow point of view if make is only available for gcc.  

And in comparison, just so to help in the decisions.

a) Make is offered with Manjaro, SUSE Tumbleweed, Ubuntu, MX-Linux Mint and More

In situations, we can use git which is provided with Fedora. The above argument applies
If make is not essential, neither is git.

So, Make on it's own is a utility that is missing from the ISO.

Comment 6 Dave Malcolm 2019-04-10 22:09:15 UTC
(In reply to Leslie Satenstein from comment #5)
> Fedora is not a server installation. It is actually a Developer platform
> that serves multiple communities.
> Make can be used for gcc, it can be used as to manage rsync type situations
> were dependencies are required.
> It can be used for python builds and more.
> 
> It is narrow point of view if make is only available for gcc.  

"make" is available via a separate RPM package.

> And in comparison, just so to help in the decisions.
> 
> a) Make is offered with Manjaro, SUSE Tumbleweed, Ubuntu, MX-Linux Mint and
> More
> 
> In situations, we can use git which is provided with Fedora. The above
> argument applies
> If make is not essential, neither is git.
> 
> So, Make on it's own is a utility that is missing from the ISO.

You appear to now be making an argument about what RPMs should be shipped in the live ISO for Workstation.

Reassigning from "gcc" to "distribution" component.

Comment 7 Leslie Satenstein 2019-04-11 23:23:31 UTC
Hi David

I write code. I test with different distributions. When I install the others, the make program is included.
They also include other software, but my issue is that the other distributions believe that make is a core utility.

Thank you for forwarding this "request" to the distribution group.


Leslie

Comment 8 Jonathan Wakely 2019-04-12 07:59:52 UTC
And as I already explained, you probably want to use:

  dnf group install "C Development Tools and Libraries"

Comment 9 Kevin Fenzi 2019-04-12 19:04:33 UTC
So, in addition to the last comment, the concept of 'default' is not too clear in Fedora anymore, we ship something like 50 different image types for different needs/uses. 

That said, you mentioned the workdstation live media. The folks in charge of the content of that deliverable are the workstation working group. You can find their communication channels here: 
https://fedoraproject.org/wiki/Workstation

The KDE spin is here:
https://fedoraproject.org/wiki/SIGs/KDE

We aren't going to make make a base package installed everywhere, but feel free to contact the above groups and make your case for them.

Comment 10 Leslie Satenstein 2019-04-13 04:13:06 UTC
FYI, 
I have been a Fedora software developer for almost 20 years. 

I do group installs for Eclipse, C Development, Editors and several other groups.
I in fact run scripts to add rpmfusion,org , D language, Python and javascript,
I run clang and really,I know that one of the above groups will include make, astyle, indent, etc.

So, essentially, Fedora is stuck in time, because, it was that way when I started with RH Core many years back, 15+ years ago.
At that time core was the feeder/migration to RedHat Linux. 
Today, Fedora is the feeder to Centos, and Centos is the migration path to RH Linux.

Issue closed.
Thank you


Note You need to log in before you can comment on or make changes to this bug.