Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1696484 - 'Software RAID' device type missing from anaconda blivet-gui interface since Fedora-Rawhide-20190403.n.1
Summary: 'Software RAID' device type missing from anaconda blivet-gui interface since ...
Keywords:
Status: CLOSED DUPLICATE of bug 1696478
Alias: None
Product: Fedora
Classification: Fedora
Component: blivet-gui
Version: rawhide
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Vojtech Trefny
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: openqa
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-04 23:59 UTC by Adam Williamson
Modified: 2019-04-09 05:52 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-09 05:52:28 UTC


Attachments (Terms of Use)
anaconda.log from an affected test (deleted)
2019-04-05 00:14 UTC, Adam Williamson
no flags Details
dbus.log from an affected test (deleted)
2019-04-05 00:14 UTC, Adam Williamson
no flags Details
program.log from an affected test (deleted)
2019-04-05 00:15 UTC, Adam Williamson
no flags Details
storage.log from an affected test (deleted)
2019-04-05 00:15 UTC, Adam Williamson
no flags Details
syslog from an affected test (deleted)
2019-04-05 00:15 UTC, Adam Williamson
no flags Details

Description Adam Williamson 2019-04-04 23:59:05 UTC
In the Fedora-Rawhide-20190403.n.1 openQA tests, the three variants of the install_blivet_software_raid test failed because the 'Software RAID' device type did not appear in the device type menu in blivet-gui within anaconda, for some reason. (Well, actually, one of them failed on https://bugzilla.redhat.com/show_bug.cgi?id=1696478 first, but if it hadn't, it seems safe to assume it would've hit this too).

blivet and blivet-gui did not change at all in that compose, so the obvious suspect is anaconda (31.7-1 landed in that compose).

I will attach logs from one of the failed tests. I don't know yet if this affects F30.

Comment 1 Adam Williamson 2019-04-05 00:04:33 UTC
blivet-gui code has this:

            if len([f[0] for f in self.available_free if f[0] == "free"]) > 1:  # number of free disk regions
                types.append((_("Software RAID"), "mdraid"))

so I guess that check is failing for some reason, dunno why though.

Comment 2 Adam Williamson 2019-04-05 00:14:13 UTC
Created attachment 1552158 [details]
anaconda.log from an affected test

Comment 3 Adam Williamson 2019-04-05 00:14:45 UTC
Created attachment 1552159 [details]
dbus.log from an affected test

Comment 4 Adam Williamson 2019-04-05 00:15:07 UTC
Created attachment 1552160 [details]
program.log from an affected test

Comment 5 Adam Williamson 2019-04-05 00:15:23 UTC
Created attachment 1552161 [details]
storage.log from an affected test

Comment 6 Adam Williamson 2019-04-05 00:15:50 UTC
Created attachment 1552162 [details]
syslog from an affected test

Comment 7 Jiri Konecny 2019-04-05 09:31:54 UTC
Vojta please look on this if this have to be adjusted because of some changes in Anaconda or it needs polishing from the blivet-gui side.

Thanks

Comment 8 Vojtech Trefny 2019-04-09 05:52:28 UTC
Closing this as a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1696478 -- it's the same problem, blivet-gui won't allow you to create RAID device, because it sees only one "available" disk -- the second disk doesn't have a partition table, so from blivet-gui pow it doesn't have enough "free space" to create a partition on it.

*** This bug has been marked as a duplicate of bug 1696478 ***


Note You need to log in before you can comment on or make changes to this bug.