Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 169643 - pam_stack is deprecated
Summary: pam_stack is deprecated
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Mike McLean
URL:
Whiteboard:
: 174681 (view as bug list)
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-09-30 16:13 UTC by Tomas Mraz
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-09 19:38:05 UTC


Attachments (Terms of Use)
New gdmsetup-pam file (deleted)
2005-09-30 16:13 UTC, Tomas Mraz
no flags Details
New gdm pam config (deleted)
2005-09-30 16:17 UTC, Tomas Mraz
no flags Details
New gdm-autologin pam config (deleted)
2005-09-30 16:18 UTC, Tomas Mraz
no flags Details

Description Tomas Mraz 2005-09-30 16:13:04 UTC
pam_stack is deprecated as it won't be accepted upstream and there is a
replacement for its functionality.

Also there is a new common pam configuration file for all config utilities
(system-config-*).

Please use the attached pam configuration files for gdm.

Comment 1 Tomas Mraz 2005-09-30 16:13:05 UTC
Created attachment 119472 [details]
New gdmsetup-pam file

Comment 2 Tomas Mraz 2005-09-30 16:17:07 UTC
Created attachment 119473 [details]
New gdm pam config

Comment 3 Tomas Mraz 2005-09-30 16:18:07 UTC
Created attachment 119474 [details]
New gdm-autologin pam config

Comment 4 Tomas Mraz 2005-10-13 17:06:40 UTC
Also the gdm and gdm-autologin configs should contain this line before the
'session optional pam_console.so'

session    required     pam_loginuid.so


Comment 5 Matthias Clasen 2006-02-04 05:33:01 UTC
*** Bug 174681 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.