Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1696359 - The composer-cli has no "Requires: lorax-composer" dependency defined
Summary: The composer-cli has no "Requires: lorax-composer" dependency defined
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: lorax
Version: 8.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: 8.0
Assignee: Brian Lane
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-04 15:40 UTC by Kyle Walker
Modified: 2019-04-04 17:22 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-04 17:22:43 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description Kyle Walker 2019-04-04 15:40:01 UTC
Description of problem:
 The composer-cli utility is essentially useless without the lorax-composer package installed.

Version-Release number of selected component (if applicable):
  composer-cli-28.14.23-1.el8

How reproducible:
 Easily

Steps to Reproduce:
1. Install composer-cli
2. Verify that the lorax-composer package is installed as well
3.

Actual results:
 No lorax-composer is installed, and therefore the composer-cli is non-functional

Expected results:
 lorax-composer is installed as a dependency of composer-cli

Additional info:

Comment 2 Kyle Walker 2019-04-04 17:22:43 UTC
After discussion with the team, this is actually an intentional packaging decision. The composer-cli utility is not inherently dependent on the lorax-composer server being installed on the same system. Therefore, in accordance with other utilities that ship *-client components which do not rely on their server-side packages, this is NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.