Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1695556 - The latest image of service catalog returns 404 on /healthz/ready
Summary: The latest image of service catalog returns 404 on /healthz/ready
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Catalog
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.10.z
Assignee: Jay Boyd
QA Contact: Jian Zhang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-03 10:47 UTC by btai
Modified: 2019-04-03 18:24 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-03 18:24:59 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description btai 2019-04-03 10:47:24 UTC
Description of problem:
After upgrade of service from 3.10.x to 3.10.119
my both api and controller pod in kube-service-catalog project are missing /health/ready checkpoint

logs from api 
I0403 09:24:15.541585       1 run_server.go:136] etcd checker called
I0403 09:24:15.547828       1 wrap.go:42] GET /healthz: (14.091503ms) 200 [[kube-probe/1.10+] 10.62.161.1:40684]
I0403 09:24:18.501982       1 wrap.go:42] GET /healthz/ready: (1.903019ms) 404 [[kube-probe/1.10+] 10.62.161.1:40694]


podstatus

apiserver-5c2j2            1/1       Running   0          1h
apiserver-sz9qw            1/1       Running   0          1h
apiserver-zn4l7            1/1       Running   0          1h
controller-manager-2p62h   0/1       Running   0          2m
controller-manager-g8ksc   0/1       Running   0          2m
controller-manager-rzn6d   0/1       Running   0          2m


Version-Release number of selected component (if applicable):

v3.10 latest

How reproducible:
always reproduce able while using v3.10 image
registry.redhat.io/openshift3/ose-service-catalog:v3.10

the controller pod are not reported as ready 
as
 we are getting this when oc describe pod controller-manager-rzn6d

  Warning  Unhealthy  3m (x655 over 58m)  kubelet, xxxx  Readiness probe failed: HTTP probe failed with statuscode: 40

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 btai 2019-04-03 10:57:57 UTC
this image version works

registry.access.redhat.com/openshift3/ose-service-catalog:v3.10.111

Comment 2 Jay Boyd 2019-04-03 18:24:59 UTC
I can't reproduce.  It sounds like the service-catalog pods were not actually upgraded.  If you reproduce this, please get full logs from Service Catalog Controller Manager that includes the startup of the pod that shows the version it is running.  Also if you can leave the cluster up for me to debug that would be most helpful.

Thanks!


Note You need to log in before you can comment on or make changes to this bug.