Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1695553 - Host failing to update from web UI
Summary: Host failing to update from web UI
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Infra
Version: future
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: ---
: ---
Assignee: Martin Perina
QA Contact: Lukas Svaty
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-03 10:38 UTC by Parth Dhanjal
Modified: 2019-04-16 05:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-16 05:11:27 UTC
oVirt Team: Infra


Attachments (Terms of Use)

Description Parth Dhanjal 2019-04-03 10:38:03 UTC
Description of problem:
Host is failing to upgrade from the Web UI.
The UI shows that an upgrade is available but upon shifting the host to maintenance and starting an upgrade no action takes place.
The engine.log shows that there are components available for upgrade but the host isn't updated. The yum.log on the host also doesn't log any action.
Going through the CLI and trying a yum update works.

Version-Release number of selected component (if applicable):
ovirt-4.3.2

How reproducible:


Steps to Reproduce:
1. Deploy a 3 node cluster with ovirt-4.2 and gluster as the storage and deploy HE
2. Upgrade the engine to oVirt-4.3
3. Try to upgrade hosts to oVirt-4.3 from web UI

Actual results:
Host doesn't upgrades

Expected results:
Host should upgrade

Additional info:

Comment 1 Sahina Bose 2019-04-04 08:01:47 UTC
Ravi, any idea which logs to look for? the engine.log has message that it's executed the upgrade yml playbook, but there are no ansible logs

Comment 2 Ravi Nori 2019-04-04 11:57:07 UTC
Looks like a duplicate of BZ 1690833. Should be fixed in 4.3.3. Can you please test with 4.3.3

Comment 3 Parth Dhanjal 2019-04-05 10:26:14 UTC
(In reply to Ravi Nori from comment #2)
> Looks like a duplicate of BZ 1690833. Should be fixed in 4.3.3. Can you
> please test with 4.3.3

I'll upgrade to 4.3.3 and try this case.
So 4.2 -> 4.3 upgrade is stuck, right? In case the resolution for the bug is provided in 4.3.3?

Comment 4 Ravi Nori 2019-04-05 13:02:44 UTC
Yes resolution for the Bug is in 4.3.3

Comment 5 Parth Dhanjal 2019-04-12 13:27:44 UTC
(In reply to Ravi Nori from comment #4)
> Yes resolution for the Bug is in 4.3.3

Hey Ravi!

I haven't yet upgraded to oVirt 4.3.3 and tried to upgrade the host.
I'll do it today/tomorrow and let you know.

Comment 6 Parth Dhanjal 2019-04-15 07:37:24 UTC
(In reply to Ravi Nori from comment #4)
> Yes resolution for the Bug is in 4.3.3

Hey Ravi!

I wasn't able to upgrade 4.3.2 to 4.3.3.
So instead I upgrade to master and tried upgrading from the UI.
I didn't face any issue with the upgrade.

I just had a doubt about why I wasn't able to upgrade to 4.3.3 from 4.3.2. I had the correct repos enabled, and upon doing an engine-upgrade-check from 4.3.2 it showed that no upgrades are available.

Comment 7 Sahina Bose 2019-04-15 10:32:00 UTC
If the issue is sorted, can we close this? You can mark this duplicate of Bug 1690833

Comment 8 Ravi Nori 2019-04-15 13:46:24 UTC
Please take a look at https://www.ovirt.org/release/4.3.3/ how to enable the right repos for testing

Comment 9 Parth Dhanjal 2019-04-16 05:11:27 UTC
(In reply to Ravi Nori from comment #8)
> Please take a look at https://www.ovirt.org/release/4.3.3/ how to enable the
> right repos for testing

Thanks!
Closing the bug.


Note You need to log in before you can comment on or make changes to this bug.