Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1695521 - On Wayland, notify_surrounding_text() crash on wl_abort() if text is longer than 4000 bytes
Summary: On Wayland, notify_surrounding_text() crash on wl_abort() if text is longer t...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk3
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1693859 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-03 09:31 UTC by Victor Stinner
Modified: 2019-04-09 15:47 UTC (History)
4 users (show)

Fixed In Version: gtk3-3.24.1-3.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-08 01:52:47 UTC


Attachments (Terms of Use)

Description Victor Stinner 2019-04-03 09:31:52 UTC
Please upgrade gtk3 to at least version 3.24.3. The current version of gtk3 in Fedora 29 (gtk3-3.24.1-2.fc29.x86_64) has a major bug when using Select All (CTRL+a) in Firefox with Wayland.

Fedora Rawhide already has the fix.

Firefox with Wayland crash on wl_abort() when selecting more than 4000 characters in a <textarea>:
https://bugzilla.mozilla.org/show_bug.cgi?id=1539773

On Wayland, notify_surrounding_text() crash on wl_abort() if text is longer than 4000 bytes:
https://gitlab.gnome.org/GNOME/gtk/issues/1783

Comment 1 Victor Stinner 2019-04-03 09:40:57 UTC
I created a PR to update gtk3 to 3.24.7 in Fedora 29:
https://src.fedoraproject.org/rpms/gtk3/pull-request/4

I'm not sure if it's the proper workflow.

Comment 2 Fedora Update System 2019-04-03 16:50:09 UTC
gtk3-3.24.1-3.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-d67ec97b0b

Comment 3 Fedora Update System 2019-04-04 04:24:57 UTC
gtk3-3.24.1-3.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-d67ec97b0b

Comment 4 Fedora Update System 2019-04-08 01:52:47 UTC
gtk3-3.24.1-3.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 5 Alex Villacís Lasso 2019-04-09 15:47:25 UTC
*** Bug 1693859 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.