Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1695173 - symbol lookup error: /lib64/libgsttag-1.0.so.0: undefined symbol: gst_type_find_helper_get_range_full
Summary: symbol lookup error: /lib64/libgsttag-1.0.so.0: undefined symbol: gst_type_fi...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gstreamer1
Version: 28
Hardware: aarch64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Brian Pepple
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-02 15:52 UTC by William Cohen
Modified: 2019-04-02 15:59 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-02 15:59:11 UTC


Attachments (Terms of Use)

Description William Cohen 2019-04-02 15:52:23 UTC
Description of problem:

Unable to start the emacs editor because of the missing symbol in libgstbase-1.0.so.0 library.

Version-Release number of selected component (if applicable):

emacs-26.1-6.fc29.aarch64
gstreamer1-plugins-base-1.14.4-2.fc29.aarch64
gstreamer1-1.14.2-1.fc29.aarch64


How reproducible:

Everytime

Steps to Reproduce:
1. sudo dnf install emacs
2. emacs

Actual results:

$ emacs
emacs: symbol lookup error: /lib64/libgsttag-1.0.so.0: undefined symbol: gst_type_find_helper_get_range_full


Expected results:

The emacs editor starts up.

Additional info:

The aarch64 version of the /lib64/libgstbase-1.0.so.0 missing gst_type_find_helper_get_range_full.  However, both the x86_64 and i386 versions of the library work fine, so this problem doesn't affect x86 processors.

Comment 1 William Cohen 2019-04-02 15:57:47 UTC
Looks like for some reason, the machine was not getting an newest version of gstreamer1 on the machine.  Manually downloaded and installed the correct version: gstreamer1-1.14.4-1.fc29.aarch64.rpm


Note You need to log in before you can comment on or make changes to this bug.