Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1695111 - openshift-ansible always assumes kubernetes.default.svc is the first_ip in
Summary: openshift-ansible always assumes kubernetes.default.svc is the first_ip in
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Russell Teague
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-02 14:00 UTC by Juan Luis de Sousa-Valadas
Modified: 2019-04-02 14:11 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-02 14:11:43 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Juan Luis de Sousa-Valadas 2019-04-02 14:00:52 UTC
Description of problem:
The OpenShift ansible installer always assumes kubernetes.default.svc is first_ip(facts['common']['portal_net'])

My customer has for whatever historical reasons a different ip address for this service. I need to know if this configuration is supportable and we have a bug in the openshift-ansible playbooks (which should find the IP address by querying the API, which is complicated because OpenShift may not be installed at the time), or if the customer has to make sure the kubernetes.default.svc the service so that it has a the first network as its clusterIP.

Version-Release number of the following components:
My customer is at 3.6.173.0.130-1, but I see the same code for 3.0.X - 3.11.X

How reproducible:
Always

Steps to Reproduce:
1. Have a different clusterIP for kubernetes.default.svc
2. Run the openshift_facts playbook

Actual results:
The kuberntes.default.svc ip address is missing and has the first ip of the network.

Expected results:
Not quite sure

Additional info:


Note You need to log in before you can comment on or make changes to this bug.