Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1695082 - dnf bash completion is not working
Summary: dnf bash completion is not working
Keywords:
Status: CLOSED DUPLICATE of bug 1692028
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 30
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-02 12:58 UTC by RudraB
Modified: 2019-04-04 15:18 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-04 15:18:01 UTC


Attachments (Terms of Use)
set -x; sudo dnf ins<tab>*2 (deleted)
2019-04-02 12:58 UTC, RudraB
no flags Details

Description RudraB 2019-04-02 12:58:18 UTC
Created attachment 1551005 [details]
set -x; sudo dnf ins<tab>*2

Description of problem:
sudo dnf ins<tab>*2 is not working. 

Version-Release number of selected component (if applicable):
dnf-4.2.2-1.fc30.noarch

How reproducible:
every time

Steps to Reproduce:
1. In terminal, write `sudo dnf ins<tab>*2 


Actual results:
Nothing happens; terminal bell rings (Depending upon your terminal settings)

Expected results:
bash completion should complete/give options for either command/package names depending upon ur tab position

Additional info:
https://bugzilla.redhat.com/show_bug.cgi?id=1479330: I already have sqlite installed. So this is a different bug.

set -x
sudo dnf ins<tab>*2 output is attached.

Comment 1 Nils Philippsen 2019-04-04 15:18:01 UTC

*** This bug has been marked as a duplicate of bug 1692028 ***


Note You need to log in before you can comment on or make changes to this bug.