Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1695029 - Do not rely on yum in fedora kickstarts
Summary: Do not rely on yum in fedora kickstarts
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: general
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: 26.5
Assignee: Martin Styk
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-02 10:40 UTC by Lukas Slebodnik
Modified: 2019-04-09 16:53 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-09 16:53:49 UTC


Attachments (Terms of Use)

Description Lukas Slebodnik 2019-04-02 10:40:22 UTC
Description of problem:
There were recent changes in rawhide and /usr/bin/yum is not installed by default
but it is still used in anaconda post section to install restraint harness

Version-Release number of selected component (if applicable):
Beaker 26.3 

How reproducible:
Deterministic

Steps to Reproduce:
1. Reserve rawhide machine in beaker
e.g.

<job retention_tag="scratch">
  <whiteboard>fedora rawhide [rs]</whiteboard>
  <recipeSet priority="Normal">
    <recipe whiteboard="" role="RECIPE_MEMBERS" ks_meta="" kernel_options="" kernel_options_post="">
      <autopick random="false"/>
      <watchdog panic="ignore"/>
      <packages/>
      <ks_appends/>
      <repos/>
      <distroRequires>
        <and>
          <distro_family op="=" value="Fedorarawhide"/>
          <distro_variant op="=" value="Server"/>
          <distro_name op="=" value="Fedora-Rawhide-20190331.n.0"/>
          <distro_arch op="=" value="x86_64"/>
        </and>
      </distroRequires>
      <hostRequires>
        <system_type value="Machine"/>
      </hostRequires>
      <partitions/>
      <task name="/distribution/check-install" role="STANDALONE"/>
      <task name="/distribution/reservesys" role="STANDALONE">
        <params>
          <param name="RESERVETIME" value="86400"/>
        </params>
      </task>
    </recipe>
  </recipeSet>
</job>

Actual results:
After some time, machine will be in Aborted state due to timeout waiting for restraint.

Expected results:
Machine reserved without any issue

Additional info:

packaging.log contains:
16:08:37,629 DBG packaging: transaction include list
16:08:37,629 DBG packaging: ['@core', 'chrony', 'kernel', 'grub2-tools', 'chrony', 'firewalld', 'lvm2', 'langpacks-en', 'grub2', 'e2fsprogs', 'xfsprogs']
16:08:37,630 DBG packaging: transaction exclude list
16:08:37,630 DBG packaging: []
16:08:37,665 DBG dnf: No module defaults found
16:08:37,683 Level 8 dnf: Getting group metadata
16:08:37,689 Level 8 dnf: Adding group file from repository: beaker-Fedora-Everything
16:08:37,782 Level 8 dnf: Adding group file from repository: beaker-Fedora
16:08:37,819 Level 8 dnf: Adding group file from repository: anaconda
16:08:37,873 Level 8 dnf: timer: loading comps: 204 ms
16:08:37,979 DBG dnf: Adding packages from group 'core': {<libcomps.Package object 'man-db' at 0x7f1020fd9900>, <libcomps.Package object 'sssd-kcm' at 0x7f1020fd9a68>, <libcomps.Package object 'glibc' at 0x7f1020fd9870>, <libcomps.Package object 'less' at 0x7f1020fd98e8>, <libcomps.Package object 'ncurses' at 0x7f1020fd9918>, <libcomps.Package object 'shadow-utils' at 0x7f1020fd9a38>, <libcomps.Package object 'parted' at 0x7f1020fd9960>, <libcomps.Package object 'lsvpd' at 0x7f1020fd9b40>, <libcomps.Package object 'filesystem' at 0x7f1020fd9858>, <libcomps.Package object 'util-linux' at 0x7f1020fd9ab0>, <libcomps.Package object 'powerpc-utils' at 0x7f1020fd9b58>, <libcomps.Package object 'procps-ng' at 0x7f1020fd99c0>, <libcomps.Package object 'vim-minimal' at 0x7f1020fd9ac8>, <libcomps.Package object 'basesystem' at 0x7f1020fd9420>, <libcomps.Package object 'kbd' at 0x7f1020fd98d0>, <libcomps.Package object 'setup' at 0x7f1020fd9a20>, <libcomps.Package object 'passwd' at 0x7f1020fd9978>, <libcomps.Package object 'policycoreutils' at 0x7f1020fd99a8>, <libcomps.Package object 'e2fsprogs' at 0x7f1020fd9840>, <libcomps.Package object 'openssh-clients' at 0x7f1020fd9930>, <libcomps.Package object 'dnf-yum' at 0x7f1020fd97f8>, <libcomps.Package object 'dhcp-client' at 0x7f1020fd9798>, <libcomps.Package object 'NetworkManager' at 0x7f1020fd9af8>, <libcomps.Package object 'iputils' at 0x7f1020fd98b8>, <libcomps.Package object 'dnf' at 0x7f1020fd9690>, <libcomps.Package object 'iproute' at 0x7f1020fd98a0>, <libcomps.Package object 'rpm' at 0x7f1020fd99f0>, <libcomps.Package object 'plymouth' at 0x7f1020fd9990>, <libcomps.Package object 'rootfiles' at 0x7f1020fd99d8>, <libcomps.Package object 'systemd' at 0x7f1020fd9a98>, <libcomps.Package object 'sudo' at 0x7f1020fd9a80>, <libcomps.Package object 'bash' at 0x7f1020fd9738>, <libcomps.Package object 'sssd-common' at 0x7f1020fd9a50>, <libcomps.Package object 'hostname' at 0x7f1020fd9888>, <libcomps.Package object 'openssh-server' at 0x7f1020fd9948>, <libcomps.Package object 'audit' at 0x7f1020fd9828>, <libcomps.Package object 'dracut-config-rescue' at 0x7f1020fd9b10>, <libcomps.Package object 'coreutils' at 0x7f1020fd9588>, <libcomps.Package object 'curl' at 0x7f1020fd97e0>, <libcomps.Package object 'selinux-policy-targeted' at 0x7f1020fd9a08>, <libcomps.Package object 'firewalld' at 0x7f1020fd9b28>, <libcomps.Package object 'dnf-plugins-core' at 0x7f1020fd9ae0>}
16:08:37,990 WRN dnf: No match for group package "lsvpd"
16:08:37,992 WRN dnf: No match for group package "powerpc-utils"
16:08:37,997 WRN dnf: No match for group package "dnf-yum"
16:08:38,046 Level 8 dnf: timer: depsolve: 40 ms
16:08:38,052 INF packaging: checking dependencies: success
16:08:38,189 DBG packaging: Size from DNF: 878.2 MiB


program.log contains:
16:13:24,813 INF program: + yum check-update
16:13:24,813 INF program: + true
16:13:24,813 INF program: + cat
16:13:24,813 INF program: + cat
16:13:24,813 INF program: + yum -y install restraint-rhts
16:13:24,813 INF program: /tmp/ks-script-9po1bif7: line 208: yum: command not found

Comment 1 Lukas Slebodnik 2019-04-02 10:42:00 UTC
It would be good to use dnf to install restraint by default
and fall back to yum if /usr/bin/dnf does not exist.


Note You need to log in before you can comment on or make changes to this bug.