Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1694957 - Tempest test test_resize_server_revert_with_volume_attached is failing
Summary: Tempest test test_resize_server_revert_with_volume_attached is failing
Keywords:
Status: CLOSED DUPLICATE of bug 1678681
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova
Version: 14.0 (Rocky)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Artom Lifshitz
QA Contact: nova-maint
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-02 07:22 UTC by Michal Pryc
Modified: 2019-04-04 20:44 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-04 20:44:33 UTC
Target Upstream Version:


Attachments (Terms of Use)
Full traceback from tempest failure. (deleted)
2019-04-02 07:22 UTC, Michal Pryc
no flags Details

Description Michal Pryc 2019-04-02 07:22:14 UTC
Created attachment 1550895 [details]
Full traceback from tempest failure.

The tempest test test_resize_server_revert_with_volume_attached is failing on the following setup:

 RHEL 7.6 with OSP 14 that has two or more compute nodes core_puddle: 2019-03-06.1.


Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/tempest/api/compute/servers/test_server_actions.py", line 66, in tearDown
    self.server_check_teardown()
  File "/usr/lib/python2.7/site-packages/tempest/api/compute/base.py", line 206, in server_check_teardown
    cls.server_id)
  File "/usr/lib/python2.7/site-packages/tempest/common/waiters.py", line 124, in wait_for_server_termination
    raise lib_exc.DeleteErrorException(resource_id=server_id)
tempest.lib.exceptions.DeleteErrorException: Resource 24e27bc3-1ddd-48b2-91a6-2f84bc95c716 failed to delete and is in ERROR status
}}}

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/tempest/lib/decorators.py", line 112, in wrapper
    raise exc
tempest.lib.exceptions.TimeoutException: Request timed out
Details: (ServerActionsTestJSON:test_resize_server_revert_with_volume_attached) Server 24e27bc3-1ddd-48b2-91a6-2f84bc95c716 failed to reach ACTIVE status and task state "None" within the required time (300 s). Current status: REVERT_RESIZE. Current task state: resize_reverting.

Comment 4 Artom Lifshitz 2019-04-04 20:44:33 UTC
Given that I found the following in ./compute-0/var/log/containers/nova/nova-compute.log, I think we can safely close this as a duplicate of 1678681.

2019-03-26 05:06:46.457 1 WARNING nova.virt.libvirt.driver [req-5fb7b6c8-ce0f-4442-9549-05c3edb5e7f6 1a79c6de9281494db7e56254a27ebbde 4dd6f09621954654adecbb1fbe500131 - default default] [instance: 24e27bc3-1ddd-48b2-91a6-2f84bc95c716] Timeout waiting for [('network-vif-plugged', u'3ba47795-3acb-4fec-b96e-98cfc9236abd')] for instance with vm_state resized and task_state resize_reverting.: Timeout: 300 seconds

and 

2019-03-26 05:06:46.775 1 ERROR nova.compute.manager [req-5fb7b6c8-ce0f-4442-9549-05c3edb5e7f6 1a79c6de9281494db7e56254a27ebbde 4dd6f09621954654adecbb1fbe500131 - default default] [instance: 24e27bc3-1ddd-48b2-9
1a6-2f84bc95c716] Setting instance vm_state to ERROR: VirtualInterfaceCreateException: Virtual Interface creation failed

*** This bug has been marked as a duplicate of bug 1678681 ***


Note You need to log in before you can comment on or make changes to this bug.