Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1694912 - NetworkManager Keyfile Plugin Failed to Add Settings
Summary: NetworkManager Keyfile Plugin Failed to Add Settings
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-02 03:34 UTC by Yupeng Chang
Modified: 2019-04-02 09:43 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-02 09:43:55 UTC


Attachments (Terms of Use)
Patch file to fix this issue in NetworkManager 1.16.0 (deleted)
2019-04-02 03:34 UTC, Yupeng Chang
no flags Details | Diff

Description Yupeng Chang 2019-04-02 03:34:49 UTC
Created attachment 1550865 [details]
Patch file to fix this issue in NetworkManager 1.16.0

Description of problem:
Since NetworkManager 1.14.x, keyfile plugin cannot work properly.

When you set a network device in /etc/network/interface, NetworkManager still use DHCP to obtain the IP address.

Version-Release number of selected component (if applicable):

1.14.x ~ 1.16.0

How reproducible:

set eth0 to static in /etc/network/interface

Actual results:

NetworkManager reports "nm-settings.c xxx: assertion 'failed' "

Expected results:

NetworkManager can set IP address correctly

Additional info:

I have already addressed the bug, it is a typo in file 
src/settings/plugins/ifupdown/nms-ifupdown-plugin.c

And I have already submitted the bug report and patch file at NetworkManager's bug tracker, following is the URL
https://gitlab.freedesktop.org/NetworkManager/NetworkManager/issues/145

However, it seems that no one cares about this bug.
So I try to submit this bug at Fedora bugzilla. Please someone push the NetworkManager team to fix this ugly typo.

Attached is the patch for NetworkManager 1.16.0

Comment 1 Beniamino Galvani 2019-04-02 09:43:55 UTC
Thanks, patch applied to master:

https://gitlab.freedesktop.org/NetworkManager/NetworkManager/commit/1dd67583e3eecba09ee983ef6a443ded64303846

and nm-1-16 branch.


Note You need to log in before you can comment on or make changes to this bug.