Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1694900 - The logging couldn't be upgrade as it is using latest tag [NEEDINFO]
Summary: The logging couldn't be upgrade as it is using latest tag
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 4.1
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Jeff Cantrill
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-02 02:21 UTC by Anping Li
Modified: 2019-04-03 13:00 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-02 12:59:40 UTC
Target Upstream Version:
jcantril: needinfo? (jforrest)


Attachments (Terms of Use)

Description Anping Li 2019-04-02 02:21:16 UTC
Description of problem:
The clusterlogging is using the tag latest in deployment,cronjob and DaemonSet. The imagePullPolicy are IfNotPresent. In this case, the image couldn't be updated once the image are refreshed in registry. it should use version in CSV. 


In csv/clusterlogging.v4.1.0
                - name: ELASTICSEARCH_IMAGE
                    value: quay.io/openshift/origin-logging-elasticsearch5:latest
                  - name: FLUENTD_IMAGE
                    value: quay.io/openshift/origin-logging-fluentd:latest
                  - name: KIBANA_IMAGE
                    value: quay.io/openshift/origin-logging-kibana5:latest
                  - name: CURATOR_IMAGE
                    value: quay.io/openshift/origin-logging-curator5:latest
                  - name: OAUTH_PROXY_IMAGE
                    value: quay.io/openshift/origin-oauth-proxy:latest
                  - name: RSYSLOG_IMAGE
                    value: docker.io/viaq/rsyslog:latest
                  image: quay.io/openshift/origin-cluster-logging-operator:latest
                  imagePullPolicy: IfNotPresent
                  name: cluster-logging-operator
                  
In csv/elasticsearch-operator.v4.1.0
                - name: OPERATOR_NAME
                  value: elasticsearch-operator
                - name: PROXY_IMAGE
                  value: quay.io/openshift/origin-oauth-proxy:latest
                image: quay.io/openshift/origin-elasticsearch-operator:latest
                imagePullPolicy: IfNotPresent
                name: elasticsearch-operator


oc get cronjob curator -o json |jq '.metadata.name,.spec.jobTemplate.spec.template.spec.containers[].image,.spec.jobTemplate.spec.template.spec.containers[].imagePullPolicy'
"curator"
"quay.io/openshift/origin-logging-curator5:latest"
"IfNotPresent"


#oc get deployment -o json |jq '.items[] | .metadata.name,.spec.template.spec.containers[].image,.spec.template.spec.containers[].imagePullPolicy' 
"cluster-logging-operator"
"quay.io/openshift/origin-cluster-logging-operator:latest"
"IfNotPresent"
"elasticsearch-cdm-zmcwl3tu-1"
"quay.io/openshift/origin-logging-elasticsearch5:latest"
"quay.io/openshift/origin-oauth-proxy:latest"
"IfNotPresent"
"IfNotPresent"
"kibana"
"quay.io/openshift/origin-logging-kibana5:latest"
"quay.io/openshift/origin-oauth-proxy:latest"
"IfNotPresent"
"IfNotPresent"

oc get ds fluentd -o json  |jq '.metadata.name,.spec.template.spec.containers[].image,.spec.template.spec.containers[].imagePullPolicy'
"fluentd"
"quay.io/openshift/origin-logging-fluentd:latest"
"IfNotPresent"



Version-Release number of selected component (if applicable):
v4.x

How reproducible:
100%

Steps to Reproduce:
1. Check the image version and imagePullPolicy after deploy clusterlogging via Market Place.
2. 

Actual results:
The image tag is latest, the imagePullPolicy is  IfNotPresent
 
Expected results:
The image tag is version, for example: v4.1
 
Additional info:

Comment 1 Jeff Cantrill 2019-04-02 12:59:40 UTC
This is not a bug.  The actual release process for OLM operators will bump the version of the CSV and modify the image with some CI process.


Note You need to log in before you can comment on or make changes to this bug.