Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1694846 - long file cat seems to hang playback in the browser
Summary: long file cat seems to hang playback in the browser
Keywords:
Status: NEW
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: cockpit-session-recording
Version: 8.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Kirill Gliebov
QA Contact: Scott Poore
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-01 20:24 UTC by Scott Poore
Modified: 2019-04-03 07:49 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
journal export (deleted)
2019-04-01 20:28 UTC, Scott Poore
no flags Details

Description Scott Poore 2019-04-01 20:24:44 UTC
Description of problem:

If I cat a long file in a recorded session, playback hangs the browser tab.

Attempted in both Chrome and Firefox with the same results.  

Version-Release number of selected component (if applicable):
cockpit-session-recording-1-29.el8.noarch

How reproducible:
Unknown.

Steps to Reproduce:
1.  Install tlog and cockpit-session-recording
2.  Configure SSSD to enable session recording for all users
3.  login as local user and cat /usr/share/dict/linux.words
5.  exit
6.  Login to cockpit and select session from under Session Recording
7.  click play icon


Actual results:
playback hangs and I see an error about a web page slowing down the brower.


Expected results:

playback full ouput as normal.


Additional info:

Comment 1 Scott Poore 2019-04-01 20:25:33 UTC
FYI, this seems to affect other cases where there's a lot of output fast such as:

find /

Comment 2 Scott Poore 2019-04-01 20:28:57 UTC
Created attachment 1550743 [details]
journal export

Generated this journal export with:

journalctl -xel _EXE=/usr/bin/tlog-rec-session --since 14:55:20 --until 14:55:40 --lines=all -o export > /tmp/tlog-long_file_cat.export

You should be able to test with import like:

cat  /tmp/tlog-long_file_cat.export | /usr/lib/systemd/systemd-journal-remote -o /var/log/journal/remote/remote-192.168.122.80.journal -

Comment 3 Kirill Gliebov 2019-04-03 07:46:06 UTC
I just tested this on my side and I am definitely confirming the problem. 
My first idea about how to fix this is to replace old term.js with xterm.js. I already tried this and it worked faster without hanging browser, but resizing feature might be compromised in case of such replacement. Nevertheless, I believe this will be a right way to do, since Cockpit migrate to xterm.js already.

Comment 4 Kirill Gliebov 2019-04-03 07:49:20 UTC
One more thing. So for xterm test I used session recording on my host, but doing the same - cat /usr/share/dict/linux.words.
But xterm solution with xterm has no effect on the attached session in BZ. Could it be somehow related to some of the tlog params? It is definitely problem of cockpit-session-recording, but just would like to know.


Note You need to log in before you can comment on or make changes to this bug.