Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1694786 - Heavy screen flickering with kernel 5.0.4
Summary: Heavy screen flickering with kernel 5.0.4
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 29
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-01 16:56 UTC by kevin
Modified: 2019-04-14 17:22 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-14 17:22:36 UTC


Attachments (Terms of Use)

Description kevin 2019-04-01 16:56:24 UTC
Description of problem:

After updating to kernel version 5.0.4 We experience some heavy screen flickering on a  Dell XPS 15 9570. 
Actually it is a black screen which goes on and off.
When you connect an external monitor then an actual image is displayed on it. The external monitor is also flickering. When you close the lid of the XPS the flickering on the external monitor stops and everything works fine.


How reproducible:


Steps to Reproduce:
1. Fedora 29 on a dell XPS 15 9570
2. update to newer kernel 5.0.4
3. boot the system

Actual results:
Screen is black and flickering

Expected results:
Everything works fine.

Additional info:
The dmesg logs and journalctl print nothing while this is happening.
Already tried i915.enable_psr=0 but it did not work 

BOOT_IMAGE=/vmlinuz-5.0.4-200.fc29.x86_64 root=/dev/mapper/fedora-root ro resume=/dev/mapper/fedora-swap rd.lvm.lv=fedora/root rd.lvm.lv=fedora/swap rhgb quiet nouveau.modeset=0 LANG=en_US.UTF-8

Comment 1 David Bauer 2019-04-02 16:10:38 UTC
I have the same problem with my Thinkpad X260 since kernel 5.0.4. After kernel update to 5.0.5 problem still persist.
Screen flickers heavy while the mouse is being moved or typing on keyboard.

Comment 2 David Bauer 2019-04-09 17:05:11 UTC
Problem still persist with kernel 5.0.6.
As a temporary solution using the kernel parameter i915.enable_psr=0 fixed the issue for me.

Comment 3 kevin 2019-04-09 17:21:50 UTC
For me the problem still persists in kernel 5.0.6 but i915.enable_psr=0 is not working.

Comment 4 kevin 2019-04-14 17:22:36 UTC
The problem is gone with kernel 5.0.7

The update to 5.0.7 also updated the wifi firmware and some mesa and dri stuff.
Dont know what exactly fixed it but it works like a charm now.


Note You need to log in before you can comment on or make changes to this bug.