Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 169476 - Leave power buttons to gnome-power-manager
Summary: Leave power buttons to gnome-power-manager
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: acpid
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
: 111958 (view as bug list)
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-09-28 17:26 UTC by Matthias Clasen
Modified: 2015-03-05 01:15 UTC (History)
8 users (show)

Fixed In Version: FC6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-16 08:58:26 UTC


Attachments (Terms of Use)

Description Matthias Clasen 2005-09-28 17:26:20 UTC
With gnome-power-manager in rawhide, we have a conflict over who handles
the power button.

Comment 1 Richard Hughes 2005-09-28 17:34:15 UTC
what do we need the acpid daemon for? for me the only thing it only did was
watch the power button..

With regard to pmud, acpid and apmd, they can all be removed (to extras?) for
FC5 in my opinion. HAL handles most stuff now and is a better solution than the
arch specific hacks and scripts that those legacy daemons are.


Comment 2 Jef Spaleta 2005-11-06 18:46:42 UTC
gnome-power-manager is going to be running all the time even for people running
kde desktops?  

-jef

Comment 3 Bart Vanbrabant 2006-01-20 12:11:16 UTC
The sample config file /etc/acpi/events/sample.conf really shouldn't handle the
shutdown when gnome-power-manager is running. Because it's really confusing now.
You get the gnome-shutdown dialog when pressing the powerbutton but before you
can press a button you're system goes down because of the acpid action.

Comment 4 Phil Knirsch 2006-02-10 13:33:24 UTC
I'll be looking into that. Maybe making the script there a little more
intelligent and checking wether X11 and/or gnome-power-manager is running before
doing any actions might work, but need to test this out myself first.

Read ya, Phil

Comment 5 Phil Knirsch 2006-02-10 13:49:09 UTC
*** Bug 111958 has been marked as a duplicate of this bug. ***

Comment 7 Simon Goodall 2006-03-26 15:32:25 UTC
This is still a problem in fc5. Shouldn't the sample script be disabled. After
all it is a *sample*.

Comment 8 Matthias Saou 2006-07-04 12:39:15 UTC
And still in FC development (pre FC6). I ran into that problem too :
- Press the power button in GNOME
- See the shutdown dialog box appear... for about 1 second
- See the computer shut down...

As Simon just wrote : Why not just comment out the two lines from sample.conf?
Who really expects to install acpid and use only the power button? Until really
useful defaults are in place (see #81142), it would be worth simply disabling
this (now) conflicting behavior.

Comment 9 Renato Ramonda 2006-08-02 15:18:01 UTC
I'd like to second the motion for the sample.conf to be commented out: I ran in
the usual problem with my new laptop. 

I press the power button, see for half a second the end session dialog, and the
machine starts to power down.

The postinstall script of gnome-power-manager could actually comment those lines
out, and upon uninstall maybe re-decomment them.

Or simply put them in, but commented by default.

Comment 10 Leslie Satenstein 2006-12-21 16:14:53 UTC
I am running FC6 Xen and my grandson touched the front power button (desktop pc)
instead of the button for the dvd drive.

Power manager setting is set to ASK, on button depress, but the system shut down,

There needs to be either a built-in delay or to fix the gnome intercept to ask
for action to take. (shutdown or sleep)
 

Comment 11 Phil Knirsch 2007-05-16 08:58:26 UTC
FC6 should contain the power.conf script that checks if there is a
gnome-power-manager running and if it does leaves it up to gnome-power-manager
to do the work.

Tried and tested it on a fresh FC6 and FC-devel here.

Read ya, Phil

Comment 12 Leslie Satenstein 2007-05-16 21:21:18 UTC
FC7 appears to have the right kind of fix for the desktop pc.
It presents a popup screen with options.

Horrah!!


Note You need to log in before you can comment on or make changes to this bug.