Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1694622 - ovn- upgrade from osp13 to osp14 failed on tripleo-upgrade: was the overcloud upgrade preparation successful task
Summary: ovn- upgrade from osp13 to osp14 failed on tripleo-upgrade: was the overclou...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 14.0 (Rocky)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: ---
Assignee: RHOS Maint
QA Contact: Sasha Smolyak
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-01 09:15 UTC by Eran Kuris
Modified: 2019-04-08 07:29 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-04 13:37:37 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Eran Kuris 2019-04-01 09:15:13 UTC
Description of problem:
upgrade process from osp13-ovn to osp14-ovn failed with error:

TASK [tripleo-upgrade : was the overcloud upgrade preparation successful.] *****
task path: /home/rhos-ci/jenkins/workspace/DFG-network-networking-ovn-upgrade-13-14_director-rhel-virthost-3cont_2comp_2net-ipv4-geneve-composable/infrared/plugins/tripleo-upgrade/infrared_plugin/roles/tripleo-upgrade/tasks/upgrade/overcloud_upgrade_prepare.yml:46
Thursday 28 March 2019  15:20:20 +0000 (0:00:26.788)       0:04:55.978 ******** 
fatal: [undercloud-0]: FAILED! => {
    "changed": false
}

MSG:

Overcloud upgrade preparation step failed... :(

	to retry, use: --limit @/home/rhos-ci/jenkins/workspace/DFG-network-networking-ovn-upgrade-13-14_director-rhel-virthost-3cont_2comp_2net-ipv4-geneve-composable/infrared/plugins/tripleo-upgrade/infrared_plugin/main.retry

PLAY RECAP *********************************************************************
undercloud-0               : ok=91   changed=48   unreachable=0    failed=1   
Version-Release number of selected component (if applicable):

core_puddle: 2019-03-18.1 [13]
core_puddle: 2019-03-06.1 [14]
How reproducible:
100%

Steps to Reproduce:
1.Run ci upgrade job
2.
3.

Actual results:


Expected results:


Additional info:
https://rhos-qe-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/view/DFG/view/network/view/networking-ovn/job/DFG-network-networking-ovn-upgrade-13-14_director-rhel-virthost-3cont_2comp_2net-ipv4-geneve-composable/83/console

Comment 1 Lucas Alvares Gomes 2019-04-02 13:51:04 UTC
The real error seems to be:

2019-03-28 11:19:48 | 2019-03-28 11:19:48.543 47871 ERROR openstack [-] Error: The following files were not found: /usr/share/openstack-tripleo-heat-templates/environments/services-docker/neutron-ovn-ha.yaml: CommandError: Error: The following files were not found: /usr/share/openstack-tripleo-heat-templates/environments/services-docker/neutron-ovn-ha.yaml[00m
2019-03-28 11:19:48 | 2019-03-28 11:19:48.545 47871 INFO osc_lib.shell [-] END return value: 1[00m

Found at undercloud-0/home/stack/overcloud_upgrade_prepare.log

Comment 3 Raviv Bar-Tal 2019-04-04 13:37:37 UTC
This is not a bug with the upgrade procedure.
The issue is that ovn template directory was changed between releases,
We will change the template directory within the test or within the tripleo-upgrade plugin

See Jira ticket:
https://projects.engineering.redhat.com/projects/RHOSINFRA/issues/RHOSINFRA-1686?filter=allopenissues

Comment 4 Eran Kuris 2019-04-08 07:29:07 UTC
(In reply to Raviv Bar-Tal from comment #3)
> This is not a bug with the upgrade procedure.
> The issue is that ovn template directory was changed between releases,
> We will change the template directory within the test or within the
> tripleo-upgrade plugin
> 
> See Jira ticket:
> https://projects.engineering.redhat.com/projects/RHOSINFRA/issues/RHOSINFRA-
> 1686?filter=allopenissues


this is the link to the ticket
https://projects.engineering.redhat.com/browse/RHOSINFRA-2475


Note You need to log in before you can comment on or make changes to this bug.