Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1694358 - Display problems with kernels 5.0+ on XPS 9575 with Vega M
Summary: Display problems with kernels 5.0+ on XPS 9575 with Vega M
Keywords:
Status: NEW
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 29
Hardware: x86_64
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-30 18:19 UTC by rofer
Modified: 2019-03-30 18:49 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)
journalctl with a broken, then working boot (deleted)
2019-03-30 18:19 UTC, rofer
no flags Details

Description rofer 2019-03-30 18:19:22 UTC
Created attachment 1549892 [details]
journalctl with a broken, then working boot

Description of problem:
Ever since I got 5.0 kernels I've had display problems that make my laptop unusable. Booting up the screen goes black before I get to the decryption prompt. Both the internal display and an external display (connected through a USB-C to HDMI connector) show anything beyond some flashing of the backlight.

With a USB-C to DP adapter I get some flickering and a lot of latency, but I am able to type in my decryption password. Afterwards the display is simply blank. However, I am able to switch over to a text console.

In journalctl I see some errors that look relevant:
Mar 30 13:42:55 xps15.home.rofer.me org.gnome.Shell.desktop[2986]: glamor: No eglstream capable devices found
...
Mar 30 13:43:03 xps15.home.rofer.me gnome-shell[2986]: Failed to set CRTC mode 1920x1080: Permission denied
Mar 30 13:43:03 xps15.home.rofer.me gnome-shell[2986]: Failed to set CRTC mode 2560x1440: Permission denied
Mar 30 13:43:03 xps15.home.rofer.me gnome-shell[2986]: Failed to disable CRTC
(the last line is repeated 7 times total)

Kernel 4.20.16 works, kernels 5.0.5 and 5.1.0 (from fedora-rawhide-kernel-nodebug) don't.

Version-Release number of selected component (if applicable):
5.0.5

How reproducible:
100% reproducible. My laptop is unusable without switching back to a 4.20 kernel.

Steps to Reproduce:
1. Boot latop
2. Select a kernel

Actual results:
Blank screen.

Expected results:
Normal startup process works.

Additional info:

Comment 1 rofer 2019-03-30 18:49:53 UTC
Looks like this is Wayland-related.

Stopping GDM from using Wayland (by add uncommenting WaylandEnable=false in /etc/gdm/custom.conf) lets GDM work. If I then login to an xorg session things appear to be working.


Note You need to log in before you can comment on or make changes to this bug.