Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1694311 - Deleting a project does not remove old packages
Summary: Deleting a project does not remove old packages
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Copr
Classification: Community
Component: backend
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Suchý
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-30 11:56 UTC by kitsune.solar
Modified: 2019-04-15 07:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-15 07:33:56 UTC


Attachments (Terms of Use)

Description kitsune.solar 2019-03-30 11:56:30 UTC
Description of problem:

Deleting a project does not remove old packages.

I want to completely remove the project and all its assemblies. But I can not do it.

I deleted the old builds. But they are still present in the repository.

Then I deleted the whole project and re-created it. But the old versions of the packages remained.

Because of this, I cannot install a new version of the package. The new version of the package is smaller than the latest old version. From the repository constantly put the last old one.

Example:
Actual builds: https://copr.fedorainfracloud.org/coprs/marketplace/fedora-meta-redis/builds/

Bad builds: https://copr-be.cloud.fedoraproject.org/results/marketplace/fedora-meta-redis/fedora-29-x86_64/


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Remove Copr Project
2. Go to https://copr-be.cloud.fedoraproject.org/results/{user}/{project}/fedora-29-x86_64/


Actual results:


Expected results:


Additional info:

Comment 1 Pavel Raiskup 2019-04-15 07:33:56 UTC
This was probably caused by stucked action log on backend, and now it is removed
once it got unstucked.
https://copr-be.cloud.fedoraproject.org/results/marketplace/fedora-meta-redis/
(404)

I'm marking this as resolved.  Feel free to reopen if this occurs again,
and sorry for inconvenience.


Note You need to log in before you can comment on or make changes to this bug.