Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1694209 - Running sushi emulator exists with: ERROR in main: libvirt driver not loaded
Summary: Running sushi emulator exists with: ERROR in main: libvirt driver not loaded
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic
Version: 14.0 (Rocky)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: RHOS Maint
QA Contact: mlammon
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-29 19:13 UTC by Alexander Chuzhoy
Modified: 2019-04-11 10:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-11 10:40:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 611859 None None None 2019-03-31 07:49:52 UTC

Description Alexander Chuzhoy 2019-03-29 19:13:50 UTC
Running sushi emulator exists with:   ERROR in main: libvirt driver not loaded

Environment:
sushy-tools-0.5.0


Steps to reproduce:
[stack@undercloud-0 ~]$ /usr/bin/sushy-emulator -i 172.16.0.95 --port 54321 --libvirt-uri "qemu+ssh://root@172.16.0.1/system"
[2019-03-29 15:13:31,587] ERROR in main: libvirt driver not loaded

Comment 1 Alexander Chuzhoy 2019-03-29 20:57:27 UTC
Was missing the libvirt-python rpm.


We need to make sure that either this RPM is always installed or we document it.

Comment 2 Ilya Etingof 2019-03-31 07:49:53 UTC
We made external dependencies optional because not all of them may be present on every platform. See relevant patch linked to this bug.

It is documented upstream [1].

1. https://github.com/openstack/sushy-tools/blob/master/doc/source/install/index.rst

Comment 3 Dmitry Tantsur 2019-04-11 10:40:11 UTC
I think right approach is to package sushy-tools in RDO with all the dependencies and use it from there (I assume you did pip install?). Since this is an issue in a package outside of OSP, I'm closing the bug.


Note You need to log in before you can comment on or make changes to this bug.