Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1694151 - Can not get Gnome display to come up after install and P1 and X1 Extreme model lenovo laptops
Summary: Can not get Gnome display to come up after install and P1 and X1 Extreme mode...
Keywords:
Status: CLOSED DUPLICATE of bug 1687489
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: gnome (assorted, untriaged)
Version: 8.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Ray Strode [halfline]
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-29 16:24 UTC by David Ober
Modified: 2019-03-29 17:59 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-29 17:59:51 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description David Ober 2019-03-29 16:24:34 UTC
Description of problem: Install 8.0 RC2 using latest BIOS 1.20 and you get no X-display is just hangs, 


Version-Release number of selected component (if applicable):


How reproducible: Always


Steps to Reproduce:
1.Install using debug non graphical mode (graphical mode has a bug)
2.Finish installing and reboot
3. No display is coming up

Actual results: Blank display


Expected results:Should boot to license acceptance screen


Additional info: since nomodeset is already on the kernel boot line disabling the graphics is not helping

Comment 1 David Ober 2019-03-29 16:27:30 UTC
After much debugging I find that if you boot into single user mode and set the default target to multi-user you can get to a coomand prompt.  At this point if you manually add two xorg packages xorg-x11-drv-fbdev and xorg-x11-drv-vesa you can set the default mode back to graphical and all will work

Comment 2 Ray Strode [halfline] 2019-03-29 17:59:51 UTC
Thanks for the report.

I'm assuming the affected hardware is a laptop with new model NVIDIA graphics? I believe this issue is already reported as bug 1687489 .

You can work around the issue by performing a workstation install instead of a server install, or as you discovered, manually installing the fall back drivers.

For your convenience, here is a draft of the in-progress release note text related to this issue:


  The fbdev and vesa xorg video drivers are not always installed by default in RHEL 8.0.
 
  Workstations with specific models of NVIDIA graphics cards will not display the graphical 
  login window after a RHEL 8.0 Server installation.  To work around this problem, perform
  a RHEL 8.0 Workstation installation on a workstation machine. If a RHEL 8.0 Server
  install is required on the workstation, manually install the xorg-x11-drv-fbdev and
  xorg-x11-drv-vesa video drivers after installation.

*** This bug has been marked as a duplicate of bug 1687489 ***


Note You need to log in before you can comment on or make changes to this bug.