Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1693203 - [OSP15][Undercloud][healthcheck] failed healthcheck for ovn_metadata_agent
Summary: [OSP15][Undercloud][healthcheck] failed healthcheck for ovn_metadata_agent
Keywords:
Status: CLOSED DUPLICATE of bug 1689671
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Cédric Jeanneret
QA Contact: Roee Agiman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-27 10:35 UTC by Artem Hrechanychenko
Modified: 2019-03-27 12:29 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-27 12:29:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 648027 None None None 2019-03-27 12:29:14 UTC

Description Artem Hrechanychenko 2019-03-27 10:35:58 UTC
Description of problem:
After Overcloud installation

check health-check for container on Compute node

[heat-admin@compute-0 ~]$ sudo systemctl status tripleo_ovn_metadata_agent_healthcheck.service
● tripleo_ovn_metadata_agent_healthcheck.service - ovn_metadata_agent healthcheck
   Loaded: loaded (/etc/systemd/system/tripleo_ovn_metadata_agent_healthcheck.service; disabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Wed 2019-03-27 10:22:16 UTC; 1min 11s ago
  Process: 136577 ExecStart=/usr/bin/podman exec ovn_metadata_agent /openstack/healthcheck (code=exited, status=1/FAILURE)
 Main PID: 136577 (code=exited, status=1/FAILURE)

Mar 27 10:22:16 compute-0 systemd[1]: Starting ovn_metadata_agent healthcheck...
Mar 27 10:22:16 compute-0 podman[136577]: There is no networking-ovn- process connected to ovsdb ports 6642 running in the container
Mar 27 10:22:16 compute-0 podman[136577]: exit status 1
Mar 27 10:22:16 compute-0 systemd[1]: tripleo_ovn_metadata_agent_healthcheck.service: Main process exited, code=exited, status=1/FAILURE
Mar 27 10:22:16 compute-0 systemd[1]: tripleo_ovn_metadata_agent_healthcheck.service: Failed with result 'exit-code'.
Mar 27 10:22:16 compute-0 systemd[1]: Failed to start ovn_metadata_agent healthcheck.



Container runs
f7624d8ba4f0  192.168.24.1:8787/rhosp15/openstack-neutron-metadata-agent-ovn:20190325.1          kolla_start  13 hours ago  Up 13 hours ago         ovn_metadata_agent

[heat-admin@compute-0 ~]$ sudo podman logs ovn_metadata_agent
+ sudo -E kolla_set_configs
INFO:__main__:Loading config file at /var/lib/kolla/config_files/config.json
INFO:__main__:Validating config file
INFO:__main__:Kolla config strategy set to: COPY_ALWAYS
INFO:__main__:Copying service configuration files
INFO:__main__:Deleting /etc/neutron/plugins/networking-ovn/networking-ovn-metadata-agent.ini
INFO:__main__:Copying /var/lib/kolla/config_files/src/etc/neutron/plugins/networking-ovn/networking-ovn-metadata-agent.ini to /etc/neutron/plugins/networking-ovn/networking-ovn-metadata-agent.ini
INFO:__main__:Deleting /etc/neutron/neutron.conf
INFO:__main__:Copying /var/lib/kolla/config_files/src/etc/neutron/neutron.conf to /etc/neutron/neutron.conf
INFO:__main__:Writing out command to execute
INFO:__main__:Setting permission for /var/log/neutron
INFO:__main__:Setting permission for /var/lib/neutron
INFO:__main__:Setting permission for /var/lib/neutron/ovn_metadata_haproxy_wrapper
++ cat /run_command
+ CMD='/usr/bin/networking-ovn-metadata-agent --config-file /etc/neutron/neutron.conf --config-file /etc/neutron/plugins/networking-ovn/networking-ovn-metadata-agent.ini --config-dir /etc/neutron/conf.d/networking-ovn-metadata-agent --log-file=/var/log/neutron/ovn-metadata-agent.log'
+ ARGS=
+ [[ ! -n '' ]]
+ . kolla_extend_start
++ [[ ! -d /var/log/kolla/neutron ]]
++ mkdir -p /var/log/kolla/neutron
+++ stat -c %a /var/log/kolla/neutron
++ [[ 2755 != \7\5\5 ]]
++ chmod 755 /var/log/kolla/neutron
++ . /usr/local/bin/kolla_neutron_extend_start
+ echo 'Running command: '\''/usr/bin/networking-ovn-metadata-agent --config-file /etc/neutron/neutron.conf --config-file /etc/neutron/plugins/networking-ovn/networking-ovn-metadata-agent.ini --config-dir /etc/neutron/conf.d/networking-ovn-metadata-agent --log-file=/var/log/neutron/ovn-metadata-agent.log'\'''
Running command: '/usr/bin/networking-ovn-metadata-agent --config-file /etc/neutron/neutron.conf --config-file /etc/neutron/plugins/networking-ovn/networking-ovn-metadata-agent.ini --config-dir /etc/neutron/conf.d/networking-ovn-metadata-agent --log-file=/var/log/neutron/ovn-metadata-agent.log'
+ exec /usr/bin/networking-ovn-metadata-agent --config-file /etc/neutron/neutron.conf --config-file /etc/neutron/plugins/networking-ovn/networking-ovn-metadata-agent.ini --config-dir /etc/neutron/conf.d/networking-ovn-metadata-agent --log-file=/var/log/neutron/ovn-metadata-agent.log


Version-Release number of selected component (if applicable):
OSP15 compose RHOS_TRUNK-15.0-RHEL-8-20190326.n.0

container image openstack-neutron-metadata-agent-ovn:20190325.1 

How reproducible:
Always

Steps to Reproduce:
1.Deploy undercloud OSP15 
2.Deploy Overcloud OSP15
3. check healthcheck status for container on overcloud compute node

Actual results:
There is no networking-ovn- process connected to ovsdb ports 6642 running in the container

Expected results:
service exited with exit code ==0 

Additional info:

Comment 1 Cédric Jeanneret 2019-03-27 12:29:14 UTC

*** This bug has been marked as a duplicate of bug 1689671 ***


Note You need to log in before you can comment on or make changes to this bug.